Restart Shutdown not working at all!

Discussion in 'macOS' started by skullsplitter, Jul 15, 2007.

  1. skullsplitter macrumors member

    Joined:
    May 9, 2005
    Location:
    Christchurch
    #1
    I can only restart/shutdown my MBP by holding down the power button.

    The apple menu does not work

    Pressing the power button does not bring up the shutdown options

    I have used a Mac since 2001 so this is reasonably serious for me to ask for help, after restarting I still have to option. I have tried terminal commands I read off the internet but these did not work either.

    Need help with this serious OS X bug,

    TY for the help,
    Skullsplitter
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    Create a new user account and see if you can shut down from the Apple menu from that account.
     
  3. quincymc macrumors newbie

    Joined:
    Jul 16, 2007
    #3
    Hello,

    What terminal commands did you try?

    My restart / shutdown options from apple menu dont work either (sleep suprisingly does), instead I have to do a 'sudo shutdown -h now', which works every time..

    Q
     
  4. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #4
    I haven't heard of this issue till now.

    What exactly doesn't work? If you choose "Restart..." what happens then?

    And what happens if you choose the same but pressing <OPTION> at the same time (disabling the ...), so that it (should) Restart right away?

    Does "sudo reboot" (in terminal) work every time aswell?
     
  5. quincymc macrumors newbie

    Joined:
    Jul 16, 2007
    #5
    option reboot / shutdown does nothing :(

    Also, a sudo reboot just prompts for password and still just sits there :(

    However a sudo shutdown does something quite interesting .. it kills all the daemons (nis, apache etc etc) but doesnt shut the computer down...?!

    I must admit a sudo shutdown -h now meets my needs, but I am curious as to why this is happening... And, the behaviour is the same for a 'vanilla' account..

    Quincy
     
  6. emil.s macrumors newbie

    Joined:
    Feb 7, 2007
    Location:
    Sweden
    #6
    Hi! I, and some more users at 99.se (swedish mac forum) does have the same problem.
    "sudo halt/reboot" works, but not the Apple menu, or the power button.

    It's the same for all users, so it's something whith the system...

    I can shutdown from the loginwindow(?)
    http://sandnabba.se/~emil/Screenshots/OS-X userswitch.jpg (highlighted field). Don't know what it's called in the english OS X :p
    And userswitching works, but not logout.

    Does realy noone know whats wrong?

    P.S
    The swedish tread: http://www.99.se/mac-os-x/220552-omstart-staeng-logga-ut-funkar.html
    Thanks /Emil.s
     
  7. emil.s macrumors newbie

    Joined:
    Feb 7, 2007
    Location:
    Sweden
    #7
    I installed Leopard today. Which works perfect. :)
    But the question remains... Is there a solution for this?
     
  8. ultimateceej macrumors regular

    ultimateceej

    Joined:
    Jul 24, 2007
    Location:
    Texas
    #8
    I had this exact problem about 2-3 weeks ago. Can you not log off from the apple menu either?
    It happened when I messed around with some of the .plist files like loginwindow.plist and and com.apple.loginwindow.plist in ~/Library. An archive and reinstall did not work because my settings in ~/Library were not changed or overwritten. I even made a backup of the two .plist files and copied some different ones from a friend's macbook. When that didn't work, I put my original .plist files backand POOF, it worked!!! I have no idea how but I do know that an archive and install does not do much except take up about 10 gigs with the 'Previous Systems' folder.
     

Share This Page