Restarted computer during Bootcamp installation

Discussion in 'Windows, Linux & Others on the Mac' started by hayhay7789, Jun 30, 2012.

  1. hayhay7789 macrumors newbie

    Joined:
    Jun 16, 2012
    #1
    Hi,

    I had finally gotten Bootcamp to work when during the partition process the computer froze completely. I couldn't even move the mouse. I then force restarted the computer while BootCamp was still installing. Now when I try to do the partition again it says I don't have enough free space which is true because the incomplete partition took up 20GB of the 26GB I had free. :eek:

    I can't remove the partition with Bootcamp (greyed out "Install or Remove Windows" button) as far as I'm concerned.

    What can I do to remove the incomplete partition and create a new one? :confused::confused::confused:
     
  2. hayhay7789 thread starter macrumors newbie

    Joined:
    Jun 16, 2012
  3. DaveSM macrumors member

    Joined:
    Aug 11, 2007
    #3
    Have you tried removing the partition using Disk utility or Bootcamp assistant?

    Did your computer froze during the partitionning or during the windows install?

    If your computer froze during the windows install you just have to restart the install. Otherwise you need to delete the partition and start over. I would suggest cloning your current mac os X install to an external drive and trying to solve your problem from there. Sometimes you can't solve problems on a drive that you are accessing.

    A safe option would be to completely wipe yor internal drive (from your external clone) and reinstall mac os X importing everything from your clone to be back to a blank slate.
     
  4. hayhay7789 thread starter macrumors newbie

    Joined:
    Jun 16, 2012
    #4
    I don't really want to wipe my internal drive. I don't have an external drive.

    My computer froze about 10 seconds into the partitioning process. Probably my fault, seeing as I was running iTunes, iPhoto, and final cut pro all at the same time when this finally worked and then froze.

    I can't access the "install/remove Windows" button from bootcamp because I don't have enough free space (most of my 20GB of space was taken by the incompleted partition), so using bootcamp to remove the partition is not an option.

    Disk utility only shows Macintosh HD, probably because the partition was incomplete and does not show up in disk utility.

    I think that the unused partition took the space it needed and left only a tiny tiny trace of a piece of the partition.

    Can't use disk utility or bootcamp to remove partition. What should I do other than wipe my hd?
     
  5. DaveSM, Jun 30, 2012
    Last edited: Jun 30, 2012

    DaveSM macrumors member

    Joined:
    Aug 11, 2007
    #5
    Either free up some space or get an external HD and make a backup.

    I would strongly suggest to make a backup either way. You never know when disasters strikes. A fresh and updated backup on an external drive is your best friend.

    You might be able to use the command line to restore your hard drive.

    You can run
    Code:
    diskutil list
    to see it if the partition is present or not. You should see your EFI, main partition, recovery partition and any other partition that you may have.

    The fact that your computer seemed unresponsive is a normal behaviour when you partition your current loaded partition. That was the reason why I suggested to try from an external drive.

    Another option might be to load your rescue partition or use your OS install media to use disk utility from there.

    Also you should keep more free space on your main drive for swaping.
     
  6. hayhay7789 thread starter macrumors newbie

    Joined:
    Jun 16, 2012
  7. murphychris macrumors 6502a

    Joined:
    Mar 19, 2012
    #7
    The following commands are read only, and do not modify anything on disk.

    Code:
    sudo gpt -r -vv show disk0
    diskutil info /dev/disk0s2
    diskutil resizevolume /dev/disk0s2 limits
    Please report back the results, formatting them in the forum window using CODE tags (highlight the pasted text, and click the # button in the tool bar).
     

Share This Page