Restore from backup kills Location Services on iPhone 5. Suggestions?

germinator

macrumors regular
Original poster
Apr 22, 2009
145
36
Had to have the phone replaced as my previous one died a horrible death. New device upgraded to 7.0.4, then restored from previous backup. Could not get a tracking. Apple genius erased all settings, setup phone as new, and location services works great.

Now, how do I get all my data/apps/settings etc. back without killing location services again?

Suggestions welcome...
 

iapplelove

Suspended
Nov 22, 2011
4,932
6,830
East Coast USA
Have you tried restoring from your backup a second time or just the once? If so give it another try worse case is you wipe the phone clean again assuming you didn't spend all day setting up a new phone.
 

iamMacPerson

macrumors 68030
Jun 12, 2011
2,798
950
AZ/10.0.1.1
So where are you right now? Restored from the backup, or is the phone still set up as a new device? Assusming the former, restore from your backup. Check Privacy>Location Services in the Settings app again and make sure they are turned on. If they are not, turn them on.

If they were on, and your still get getting location services, try:

Going to Settings>Privacy>Location Services turn them off, close out all apps and reboot (hard reboot (holding Home and Lock Buttons until the Apple logo apperers) might be nessacary). Go back to Location Services, turn them off, and reboot again.

Sounds weird and stupid, but this happened to me once after restoring after an update and it worked.
 

germinator

macrumors regular
Original poster
Apr 22, 2009
145
36
Restoring reproducibly kills location services. Even though it says it's enabled I can't get a tracking.

Will experiment with Reset all settings and Reset and Erase. This is going to take time.

Also, battery draw is horrible. So perhaps it isn't a bad idea to setup as new user.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.