Restore FW:2.2.1 to FW:3.1.2 "not eligible". Why??

Discussion in 'iPod touch' started by Grasshopper2Ant, Sep 20, 2010.

  1. Grasshopper2Ant macrumors newbie

    Joined:
    Apr 8, 2010
    #1
    I have a 2G iTouch 8GB (MB) model. It is at 2.2.1 firmware. I am trying to get it to 3.1.2 firmware so I can JB it. iTunes will not let me restore. I get the "device not eligible" message.

    What are my options to JB this ?? I have read I can upgrade or downgrade to any 3.x.x firmware without saving my SHSH blobs on a 2G iTouch. Can someone confirm this?

    Final question, does one need to be at 3.1.2 if I am using redsn0w 0.9.4 ??

    Thanks for any info to help!!
     
  2. Night Spring macrumors G5

    Night Spring

    Joined:
    Jul 17, 2008
    #2
    Not sure what is the exact deal with 2G touch, but "not eligible" usually means you are trying to restore to a firmware that Apple is no longer signing.
     
  3. Grasshopper2Ant thread starter macrumors newbie

    Joined:
    Apr 8, 2010
    #3
    Thanks for your reply. I tried it on two computers and got the same message. I figured it may be the signing bit but I thought I read on a 2G I could upgrade or downgrade without issue. If someone can confirm this?
     
  4. avit macrumors regular

    avit

    Joined:
    Jul 8, 2010
    Location:
    Over there
  5. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #5
    I began to type out a response to this, and got this feeling of deja-vu...I realized why: I've had this discussion elsewhere on this site recently. :)

    Rather than rehashing it here, I'll link to my other post: let me know if this helps.

    It is still a bit strange because I understood Apple to only be checking signatures on 4.0 and above with iPod touch 2G, so in theory 3.1.x shouldn't be a problem, but it is sounding more and more like with the latest iTunes, Apple may have decided to artificially prevent downgrading.

    Good luck,

    -- Nathan
     
  6. Grasshopper2Ant thread starter macrumors newbie

    Joined:
    Apr 8, 2010
    #6
    Thanks guys for your replies and ideas.

    I tried 3.1.3 firmware and I get the same "device not eligible" message, same as 3.1.2 firmware.

    I am going to try the custom .ipsw route and see what happens.

    I am using iTunes 9.0 or 9.2 and want to JB the iTouch. I am trying to update to a firmware so I can use to JB. Should I try 4.0 knowing I can never go back?
     

Share This Page