Restore hard disk icon on desktop - Preferences > General > Show HD doesn't work

Discussion in 'macOS' started by Shanny, May 1, 2010.

  1. Shanny macrumors newbie

    Joined:
    May 1, 2010
    #1
    Hi somehow the HD icon on the desktop got removed by a prev owner. When you go to Preferences > General > Show HD icon - that does not restore the icon. OS X 10.4.11 Any ideas how we can get this icon back to the desktop? Thank you
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
  3. Ice Cream Man macrumors member

    Ice Cream Man

    Joined:
    Jan 1, 2003
    Location:
    Earth
    #4
    If that's not working right there could be other incongruences as well. You may want to load OnyX and run scripts, permissions, and...well...everything. Just to clean up the system and help it become aware of things like that.
     
  4. JustinVM macrumors newbie

    Joined:
    Jan 12, 2010
    #5
    Launch your 'Script Editor.app' (Applications > AppleScripts > 'Script Editor.app') and paste the code below in to it. Then click the (green) Run button.


    tell application "System Events" to set visible of startup disk to true
    quit application "Finder"
    delay 0.8
    launch application "Finder"
     
  5. Shanny thread starter macrumors newbie

    Joined:
    May 1, 2010
    #6
    Thank you to those that provided helpful information - I will try the delete on the Finder plist and see if that fixes.
     
  6. Shanny thread starter macrumors newbie

    Joined:
    May 1, 2010
    #7
    No luck so far

    Hello - I tried deleting the plist as directed. This did not re-populate the HD icon on the desktop - any other ideas? Thank you.
     
  7. alvarez73 macrumors newbie

    Joined:
    Nov 21, 2012
    #8
    If you are still looking for a fix try this (It worked for me when I had the same problem)

    (it's a good idea to create a new account to test this first)

    Run Terminal:

    $ cd /volumes
    $ ls -lo (will show you the volume name)
    $ chflags nohidden "<volume name as shown above>"

    mine was the default - 'Macintosh HD'
    so:

    $ chflags nohidden "Macintosh HD"

    sometimes says permission denied, so you can use sudo:

    $ sudo chflags nohidden "Macintosh HD"

    then enter password. It worked on mine and I've had the problem without a fix for about 2 years, as I just created an alias to the disk when I couldn't fix it.

    A.
     

Share This Page