restore iphone 3g custom ipsw after ipad baseband update

Discussion in 'Jailbreaks and iOS Hacks' started by black iphone, Nov 29, 2010.

  1. black iphone macrumors newbie

    Jan 14, 2010
    I upgraded my baseband to 6.15 on 4.2.1. I then tried downgrading to 3.1.2 and using blackra1n to get past error 1500 with the recovery screen. It worked and my baseband was 6.15 on version 3.1.2. I tried using Cydia to install ultrasn0w but it keeps crashing so I tried restoring back to a custom 4.2.1 ipsw. I used redsn0w to put the phone into DFU mode and then used iTunes to restore to the custom 4.2.1 ipsw. It went back to the recovery screen after the restore was done. I tried jailbreaking it with redsn0w to get past the recovery screen but it didn't work. What's the proper way to restore to custom ipsw?
  2. Dav375 macrumors newbie

    Nov 30, 2010
    Take the normal 4.2.1 FW. Then you get the error 1015 in Itunes. then you use Tinyumbrella to exit the Recovery mode.

    Greetings Dav375 :D
  3. iLover1 macrumors member

    Nov 27, 2010
    why downgrade?

    4.2.1 works flawlesly on my 3G with the ipad's baseband.
    also i imagine that you upgraded bb in order to unlock.
    if it was me i would of done the unlock then try to downgrade, but thats just me and my crazy ideas
  4. aan000 macrumors newbie

    Nov 30, 2010
    I hope someone can help! I'm relatively new to jailbreaking and my iphone 3g 4.2, 6.15 is stuck at the restore screen. Is there any way to get back to 4.2? (I've tried custom firmware and tiny umbrella restore kicks, but it hasn't made it work :[).

    I got stuck in this mess after reading: I thought option A meant to get a fresh 4.2.1 and actually use the at&t sim card instead of bypassing it with redsn0w, which I did the first time.

    I was having to charged my iphone 3g 4 times within 5-6 hours, using that second method there. I managed to get 4.1 working, but i have no idea how to get that jb (not redsn0w) and unlocked, and I'm not sure if it would be worse than 4.2.

    If someone could help this noob that's been going crazy about this it would be so appreciated!

    Where I hope to end up with my 3g: getting it out of restore, pref. back to 4.2 where i don't hacktivate it, and then unlocking it for tmobile use.
  5. superkid macrumors newbie

    Jun 14, 2009
    It does not work flawlessly. I upgraded a 3g being used on t-mobile to 4.2.1 with 06.15 bb, and the gps doesn't work now. Almost every person who has upgraded to 4.2.1 with the iPad baseband has had GPS problems.

    I also need to figure out how to get push notifications working.

  6. Dav375 macrumors newbie

    Nov 30, 2010
    Do you have the shsh blobs for 4.1? Try the normal 4.1. Then you get the error 1015 because itunes can't identify the bb. then the iphone reboots to the restore screen. then get the iPhone out of the recovery with tinyumbrella. after that jb the iphone with rednsow and then unlock it with ultrasn0w

    sorry for bad english
  7. hackthatphone macrumors 68000


    Jul 28, 2010
    TinyUmbrella does not work on 4.2.1 as far as kicking the phone out of recovery mode. Been there done that.

    Unless you have solved this problem yourself, you don't know what you are talking about.

    You can downgrade back to 4.1, getting back to 4.2.1? Another issue...
  8. lancerx macrumors newbie

    Dec 3, 2010
    This is something i really want to know.. specially if i can get rid off bsb 06.15.00 in the future.....
  9. jc0lmenarez macrumors newbie

    Dec 5, 2010
    I updated my 3G to iOS 4.2.1 with BB 06.15 and it worked just perfectly (Although I have to mention that I didn't "Hacktivate" it, 'cuz I used my legal and official SIM).. I tested the WiFi, GPS, Push and all of the other native functions of the phone and they were working just fine!! I even unlocked the iPad BB with Ultrasn0w and I veryfied my phone was perfectly working..

    So I guess, the problem with the GPS and the Push notifications may rely on the way the phone is activated.. I recommend to activate the phones with their official SIMs, don't matter if it's borrowed you just need it for the activation part on iTunes then Ultrasn0w will help you!!
  10. jc0lmenarez macrumors newbie

    Dec 5, 2010
    How did you kick out the phone from RM using TinyUmbrella on iOS 4.2.1?? That's impossible!! You have to downgrade first to any iOS different of 4.2.1 and then you can use TinyUmbrella to kick out your phone from RM.. That's the way I did, and that's the way everybody has done in the web after getting stuck in RM with iOS 4.2.1 and BB 06.15.. I have iPhone 3G with iOS 4.1 and BB 06.15 unlocked
  11. jc0lmenarez macrumors newbie

    Dec 5, 2010
    This can help a lot of people!!

    I have my iPhone 3G with iOS 4.1 and the BB 06.15 unlocked with Ultrasn0w.. My GPS, Push notifications, WiFi, 3G Data, and everything else are working just fine.. I didn't hacktivated the phone, I used my legal and official SIM for it.. But I really want to upgrade to iOS 4.2.1, 'cuz I felt my phone was faster whit it before I tried to do a master restore with the original 4.2.1 FW and the BB 06.15 already flashed!! (Du-ooh).. My problem is that I can't find a Custom iOS 4.2.1 FW for 3G with no baseband update and no Hacktivation!! I'm on Windows, so I can't build my own FW.. Can anyone help me?? I would appreciate either a custom FW just for restoring and then I'd use Redsnow for JB, or a custom FW with JB included!! Thanks in advanced..
  12. warriorofgod macrumors newbie

    Dec 8, 2010
    Please Help

    I agree that your are right because i tried this method didnt work on the other hand I never used umbrella so not sure how it really works after I boot it out whats next. Anyways here is my issue I updated to 4.2.1 first then tried the jailbreak got cydia but then when I click on cydia it opens but nothing happens it just runs in the backround. i tried to restore it and now Im stuck. I just want it to work on any version. Unlock or not can I get it back working. Is it possible to get it working and unlocked at any fireware. Please help. feel free to email me.
  13. Northbadda macrumors newbie

    Dec 9, 2010
    Hey everyone, I have the same problem as warriorofgod. Please post the solution here if anyone has any. I kinda understood what jc0lmenarez said but I can't seem to be able to downgrade the firmware to any older version so that tinyumbrella becomes usable. Please help.:(
  14. argonzero macrumors newbie

    Dec 13, 2010
    Hopes this helps someone out there. I bought a 3G from a friend to mess around with. He only had 3.something on the phone so I upgraded to 4.2.1 using Redsn0w and also updated to base band 6.15. All worked well, and I was able to unlock the phone also. I decided to try bootlace/iboot/idroid also, which worked but was very slow and only lasts about 2 hours on android due to the lack of power management. In any case, the two options to remove the iboot was to run a command from console or restore, which I decided to restore. Unfortunately, I glossed over the part about having to restore to custom firmware after upgrading the baseband to 6.15. I restored the original 4.2.1, which brought me to a continuous "connect to itunes" state, even using recboot or tinyumbrella to get it out of restore mode. I tried downgrading to 3.1.3, where you restore 3.1.3 but use redsn0w to point to 3.1.2 then jailbreak, but that did not work ether although some found success.

    So I was left with a 3G with baseband 6.15 already upgraded and no booting os. The following did work for me:

    -Restored back to Original 4.1 then use tinyumbrella to exit restore mode. This phone was only version 3.something when I acquired it so there was no SHSH blobs, and it still worked. I remember reading something about SHSH blobs not applying to 3G phones.

    -I still wanted to put 4.2.1 on the phone, so I tried countless ways to do this but the only thing that worked was to restore with a custom firmware created from Pwnagetool 4.1.3. Specifically, I did not specify to upgrade the baseband, restored the custom firmware with iTunes and it booted up right after without using recboot/tinyumbrella. Note however, that when I tried restoring a custom firmware 4.2.1. with the ipad baseband 6.15, it restored but failed to boot no mater what I tried.

    Hopefully that helps some people, it seems all hit and miss since some people report doing fine with downgrading to 3.1.3. Again, this was upgrading to 4.2.1 with baseband 6.15 already updated.
  15. Lense macrumors newbie

    Dec 14, 2010
    hmm i have iphone 3gs, and i tryed ipad baseband , with 4.2.1 and redsnow,

    now im stuck i RM , how to get out ? i tryed to use snowbreze to make custom ipsw 4.1 and itunes (Shift) , but getting error in itunes. should i stand in dfu mode or rm in itunes?

    what to do to get in OS= im stuck in rm :( , tinyumbrelle,ireb, etc dosent work :(
  16. Lense macrumors newbie

    Dec 14, 2010

    1 use redsnow click firmware 4.2.1
    2 tick in redsnow just enter pwned dfu mode right now
    3 phone will to black screen and this dfu mode
    4 now restore with custom firmware the link is available below
    5 now ur phone will come to emergency mode
    6 use redsnow again and tick only cydia option
    7 ur phone will again hange on apple logo and dont worry
    8 just enter boot theater right now
    ur phone will come alive and then u can use cydia and can unlock ur phone if ur baseband is upgrade to 6.5.01 and if not then u can use cydia with both option of cydia and install ipad baseband selection and then repeat the above procedure
    MEGAUPLOAD - The leading online storage and file delivery service (

    :) recovery mode fixet!
  17. CokeM5, Dec 17, 2010
    Last edited: Dec 17, 2010

    CokeM5 macrumors newbie

    Dec 15, 2010

    Will the custom firmware work with my iPhone 3G?

    Edit: For 3G users: (4.2.1 custom firmware)
  18. kooljesh macrumors newbie

    Jan 30, 2011
  19. bigterry420 macrumors newbie

    May 8, 2011
    i have iphone 3g with 4.2.1 and upgraded baseband to 06.15.00 using redsn0w. I have ultrasn0w installed aswell and it said it was installed properly but for some reason the phone wont unlock. it just says no service. Ive tried reinstalling ultrasn0w and rejailbreaking but nothing seems to work. please help!:apple:
  20. enferrari macrumors newbie

    Jan 27, 2011
  21. awadeee macrumors 68020


    Jan 21, 2011
    Viper City
  22. enferrari macrumors newbie

    Jan 27, 2011

    It doesn't really matter. People still use old threads to find out info.
  23. SPFH73 macrumors newbie

    Aug 10, 2011
    Tried everything above and loads of other guides online!
    Nothing seems to work for my iphone at all,
    Its on a custom 4.2.1 as it should be and baseband 06.15,
    Just need it to boot and it seems like this works for everyone else!
    Does anyone have any suggestions for what i can do next?
  24. cubanmiami05 macrumors newbie

    Feb 24, 2010
    Same Situation

    HEy !! Im in the Same Situation !! I upgrade my 3g to 4.2.1 with iPad Baseband , but I want it to restore to 4.2.1 , and I keep getting error 1015 !! I downgrade it to 4.1 (it works ) , Now I want to Upgrade it to 4.2.1 !! Im stuck in DFU !! FML !!! Any suggestion !! If I found a way !! I let you guys know !: )
  25. destrukt86 macrumors newbie

    Sep 2, 2011

    Hi all!
    I need your knowledge! I’ve a big problem with my iPhone 3G, it’s not a short story, but I tell you what happened:
    I bought an iPhone 3G, JailBreaked it to 4.2.1 with redsn0w (0.9.6b5). I’m using Windows. Everything worked fine.

    Than I wanted to re-jailbreak, with redsn0w (0.9.6b6), in order to use the new battery-saver Deactive feature. Ok,

    it was fine. I had to install an application called SAM, from Cydia. I added the new SAM source to Cydia, but it didn’t

    find it, there was some error. Than some weird way, all my packages and sources dissapeared from my Cydia. I

    re-jailbreaked it, as previously, but my Cydia was not fixed tho. And here is the part when I screw everything. I

    ereased all my settings and data content from my iPhone (at Settings/General) based on a Youtube video. I was

    lame, and I didn’t read all the 30 page of comments, only when the trouble came. Since that erase, I can’t jailbreak

    my iPhone with 4.2.1, not even with 4.1, only with 3.1.3. I didn’t back up anything, not even my SHSH. I didn’t even

    know what did SHSH mean.

    I’ve almost tryed everything. My iTunes says when trying to recover, it can’t be done for some reason, ERROR code

    1015 at like 80-90% of the setup. I did let iTunes to try restore the OS it wants, than I tryed SHIFT+Click and than

    select my iPhone1,2_4.2.1_8C148_Restore.ipsw. No use, 1015. I used the program „Error 1015 Fixer”, no work. In

    most of the cases, my iPhone starts in Recovery Mode, so I had to use RecBoot (LibUsb required) to kick it out from

    Recovery Mode. When I successfully kicked it out, I could try to install the iPhone1,2_4.2.1_8C148_Restore.ipsw

    with redsn0w. No use, at the end of the installing the pineapple dude stucks with 2 messages, once at the activation

    bundle, and the 2nd time I don't remember clearly. The end was the same in every time, phone restarts before setup

    end, than it tries to get up, can't load iOS, than a new reboot, and come back in recovery mode.

    I tryed to reinstall with iTunes & redsn0w, after I used iREB. With iREB I could fix the Recovery Mode Loop, and set

    Auto-Boot on True, than I used the restore function (I think it would restore the baseband), than it puted my phone

    into pwnage DFU mode. Still no work, couldn't reinstall iOS to work.

    iRecovery didn't work as well. With Greenp0ison, I can't get trough the 'Enter DFU mode' part, I simply can not get

    into DFU mode. This is the last simptom of my iPhone 3G, I simply can not get into DFU mode. Few days before I


    I even used sn0wbreeze 2.2.1. I made my custom IPSW, Uploading WTF, but the screen is stuck at Waiting for

    iBSS... No use.

    At the end, I think the problem is with the baseband. I updated the iPad baseband, than erease all data, I can't

    reinstall, and now I think this is all the confusion come from.

    And now, my iPhone just doesn't want to turn on. :) Howevery my iTunes says the iPhone has been detected.

    This is where I am now. Please help me!

Share This Page