Restore iPhone4

Discussion in 'Jailbreaks and iOS Hacks' started by nhanda, Oct 12, 2011.

  1. nhanda macrumors newbie

    Joined:
    Oct 12, 2011
    #1
    Hi guys,

    I am having issues trying to restore my iphone4. Basically i had jailbroken my phone using the redsn0w method for baseband 4.3.5

    Now when trying to restore my phone and install the latest update iOS5, I am facing issues. When I click on "Restore" in iTunes, i get the following error -

    "The iphone XXXX could not be restored. This device isn't eligible for the requested build".

    Any help would be appreciated.

    Thanks,
    Nikhil
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Put that into DFU mode first, then restore with Itunes.
     
  3. nhanda thread starter macrumors newbie

    Joined:
    Oct 12, 2011
    #3
    Hi crystal-ex. I have already tried DFU mode. It still gives me the same issue.
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    did you check your host file & look at the advance tab of TU to make sure it point to Apple server and not Cydia?
     
  5. nhanda thread starter macrumors newbie

    Joined:
    Oct 12, 2011
    #5
    Could you kindly elaborate what you mean by TU ..and host file where exactly ?
     
  6. nhanda thread starter macrumors newbie

    Joined:
    Oct 12, 2011
    #6
    I tried in another PC as well, first time install of iTunes and then restore ...error code 3194.
     
  7. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #7
  8. nhanda, Oct 12, 2011
    Last edited: Oct 12, 2011

    nhanda thread starter macrumors newbie

    Joined:
    Oct 12, 2011
    #8
  9. GettrightPRO, Oct 13, 2011
    Last edited: Oct 13, 2011

    GettrightPRO macrumors newbie

    Joined:
    Oct 12, 2011
    #9
    I had this same issue.

    i went into the 'host' file and deleted all other server addresses, even ones with a pound symbol in front and left only the apple server. I'm pretty sure thats what solved my problem.
     

Share This Page