Restore ipod touch in restore loop

Discussion in 'iPod touch' started by Aleina, Feb 22, 2015.

  1. Aleina macrumors newbie

    Joined:
    Mar 7, 2013
    #1
    I had been using my Ipod touch 4g when it suddenly stopped working (blank screen). I put it down to a low battery and charged it. This did not seem to work. I have now come to the conclusion that I have to restore it and start again. When I connected the Ipod to the computer and when to iTunes it say it has detected an Ipod in recovery mode. I did the restore and the Ipod shows the Apple logo with the status bar at 0%. I have googled and tried downloading firmware but that has not worked. Any help would be great.
     
  2. LMC91 macrumors member

    Joined:
    Jun 17, 2014
    #2
    Hey, this allowed me to SSH into my iPod Touch and pull out any files I needed, even app/game saves, when I was in a Recovery Loop and couldn't use my iPod. But this also fixed the Recovery Loop too, after following the instructions below, use Tiny Umbrella to try kick the iPod out of the Loop, or go ahead and try restore with iTunes. Not sure if you're on PC or Mac, I've only done this on a PC myself, but I'm sure there is Mac versions or alternative software.

    Download Putty:
    http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

    Download WinSCP:
    http://winscp.net/eng/download.php

    Download SSH_RD_Rev03B.jar:
    http://www.sinfuliphone.com/showthread.php?p=781514
    In that link it mentions about needing to install 'JRE-7-Windows-i586-iftw.exe' for it to work, but you can try without it to see if it works.

    Follow the instructions here to get access into your iPod (even if you don't want to backup files, see if the mnt2 folder shows, if not follow the next step):
    https://github.com/msftguy/ssh-rd/wiki/Windows-How-To

    If /mnt2 doesn’t show, restart the instructions for Putty, and after typing in the root and password, (before typing ‘mount.sh’), enter in:

    fsck_hfs -r /dev/disk0s1s2

    It will go through a repair, wait till it’s done, and mnt2 should work. Try restoring with iTunes or kick out of the Recovery Loop with Tiny Umbrella, hope it works.
     
  3. Aleina thread starter macrumors newbie

    Joined:
    Mar 7, 2013
    #3
  4. LMC91, Apr 7, 2015
    Last edited: Apr 7, 2015

    LMC91 macrumors member

    Joined:
    Jun 17, 2014
    #4
    In the third link, it mentions needing 'RE-7-Windows-i586-iftw.exe', I know I said I wasn't sure if you needed it or not, but have you tried downloading that and trying it then? (Windows only)

    Try right click Putty and click 'Run as administrator' to see if that helps.

    Just be sure all the settings and stuff for putty is typed exactly right as well, I'm honestly not sure what might be causing it not to work.
     

Share This Page