Restore Jailbroken touch after jumping in the pool with it?

Discussion in 'iPod touch' started by FelixMC, Jun 21, 2009.

  1. FelixMC macrumors member

    Joined:
    Jan 4, 2008
    #1
    A few months ago I bought a 16GB iPod Touch and within 2 week I jailbroke it on my PC using redsn0w lite. The downside of that is that whenever the battery ran out or i would turn the ipod off, I would have to reboot it using the iBoot tool on my PC that came with the redsn0w package.

    Anyway, about a week ago I jumped into the pool without knowing I had my ipod in my pocket. Fortunately, I realized it as soon as I hit the water, and the ipod was in a dry towel within 20 seconds. The screen froze, after which it turned black and white, after which it turned off. So after looking some stuff up online, I left it for a full week in a bowl of rice and blow dried it regularly.

    Two days ago I decided to turn it on and restore in iTunes since there's probably disk damage and so on. So I plugged it in, launched iBoot and followed the usualy procedure for iBooting it. Held power & home for 10 seconds, then home for another 5 seconds. At the end of that, the 'new hardware found' sound went off and iTunes launched saying that I needed to restore the iPod. I hit restore & it downloaded the software then a window came up saying "preparing ipod for restore". My ipod turned on, displaying the apple logo against a black background, the usual for when you reboot it. The progress bar in the window completed twice, after which the ipod turned off and the progress bar went back to the beginning.After a few minutes iTunes said it could not restore the ipod due to error 1604. I repeated those steps several times with the same results. I was trying this on a Win XP Pro with USB 2.0 ports. Google didn't offer up much help either. I also tried to restore it from my mac, but my mac won't recognize the iPod at all, not matter wha I tried.

    Today, I decided to try to restore it again from my PC. I launched iBoot and started the usual process. However, the new hardware sound never came. I tried several times after which I rebooted and unplugged the iPod several times with no results. I also tried 'force restoring' it by holding home and plugging in the USB or holding home and power and all that, but I think the fact that it was jailbroken and requires iBoot to start up impedes those processes.

    Anyone have any other idea? :(
     
  2. tadad1 macrumors 6502a

    tadad1

    Joined:
    Oct 20, 2008
    #2
    The battery may just be really flat, try letting it charge for an hour or so, whack it into DFU mode connect it and if iTunes prompts you to restore just do a regular restore without worrying about iBoot.
     
  3. I3eXa macrumors 6502

    Joined:
    Aug 24, 2004
    Location:
    IdaPIMP
    #3
    yeah, it has water damage and probably won't work. I'd sell it for parts and not jump into the water anymore with expensive electronics in your pockets anymore..not much else you can do.
     

Share This Page