Restore Needed iPhone cannot make or received call."Unknown IMEI and ICCID

Discussion in 'iPhone' started by jologs, Jan 27, 2009.

  1. jologs macrumors newbie

    Joined:
    Nov 29, 2008
    #1
    hello all,

    When I turn on my iphone this morning it has an error "Restore Needed" iPhone cannot make or received call. Restore from iTunes" Then when I try to tap the "i" it says that Unknown IMEI and ICCID. And when i tried to launch the iTunes it has an error "iTunes could not connect to the iPhone because it is locked with passcode. You must enter your passcode on the iPhone before it can be used with iTunes..

    Please help, what went wrong with this? Any advise to restore my iPhone?

    Any help will be much appreciated.

    Thanks,
    Jologs
     
  2. JasonGough macrumors regular

    JasonGough

    Joined:
    Apr 25, 2005
    Location:
    Manchester, UK
    #2
    oh no!

    i've just got the same error too... was workign fine eariler in the day, just checked it now and its gone.

    It says connect to iTunes but i can't do that until i'm home. i have the same IMEI and ICCID unknown message.

    searching the internet suggests that its game over, return to Apple store for a replacment. there are also many posts of this happening to people who's iPhones are jailbroken. i'm guessing that those guys can't take it back for a free replacement tho :D

    what did you do to resolve your problem?
     
  3. C01E macrumors member

    C01E

    Joined:
    Jan 25, 2009
    #3
    This has happened to me a few times before with my iPhone 3g (Both when jailbroken and using stock firmware)

    For me I just had to remove and re-insert the SIM card once, The other two times rebooting the phone fixed it.
     
  4. cfh macrumors newbie

    Joined:
    Apr 5, 2011
    #4
    Could be sw issue - attempting reboot many times led to a solution

    My iPhone stopped mounting in iPhoto before I had the connect to restore message and the unknown IMEI and ICCID message. On the Mac end, iTunes said it couldn't sync because I needed to enter my passcode, but since the phone wouldn't boot, that wasn't an option. I left the phone plugged in overnight and it kept trying unsuccessfully to reboot itself. I tried rebooting manually a dozen or more times the next morning. Finally, success! Once rebooted, it behaved strangely with several tested apps quickly crashing. I connected the phone to a PC via USB cable and pulled off the unsynced photos manually for good measure. Then I connected it to the Mac I usually sync with and was able to sync without error. Finally, I updated the phone software (as an update had just been released), and now the phone and apps are working as they should, and the phone again mounts in and syncs with iPhoto. Although the unknown IMEI/ICCID can signal a hardware problem according to several sites, it was apparently gradual software corruption that was the problem for me. (Phone is not jailbroken.)
     

Share This Page