Restore to same version of iOS without updating?

Discussion in 'iPhone' started by jent, Oct 22, 2012.

  1. jent macrumors 6502a


    Mar 31, 2010
    I have an iPhone 4S running iOS 5.1.1 on AT&T in the U.S. AT&T has approved an unlock request I submitted, so I have to connect my iPhone to iTunes, back up, restore to factory settings, and then restore my backup onto the phone—after doing this my iPhone will re-activate with AT&T and will receive a carrier-sanctioned permanent unlock.

    I've done with this an iPhone 4 recently and it's a fairly straightforward process. Since I last did this, though, iOS 6 has come out. I'm personally not interested in upgrading my iPhone 4S to iOS 6 for the time being. I have never jailbroken my phone, but I feel that if I am currently running iOS 5.1.1 I should be able to restore to it too. I know I can do this via the iPhone itself in the Settings app, but the official iPhone unlock instructions provided by both Apple and AT&T say it must be done on an iPhone.

    Is it possible to restore an iPhone to factory settings in iTunes without updating past the current version of iOS on the phone?

    If not, is it possible to receive a carrier-provided unlock if one restores from the iPhone itself?

    Thanks for any help!
  2. Daveoc64 macrumors 601

    Jan 16, 2008
    Bristol, UK
    This won't be possible unless you have specifically saved your "SHSH blobs" when your iPhone was last activated.

    If you have no idea what that means, then you almost certainly haven't done it!

    In that case, you can only install the latest version of iOS (6.0).
  3. jent thread starter macrumors 6502a


    Mar 31, 2010
    What if I download the 5.1.1 .ipsw file from Apple's servers here and the Option-click the Restore button in iTunes, pointing it to that file? Would that work, and if so, could I then restore a 5.1.1 backup onto the fresh install without needing to upgrade to iOS 6?
  4. miragebg macrumors 6502a

    Mar 23, 2009
    You will get an error at the end of restoration process.
    As the other guy said above- not possible without SHSH, and u can obtain it only if you have jailbroken your device.
  5. Baggio macrumors 6502

    Oct 18, 2012
    No need to do restore. I have done this and all I did was test a non AT&T SIM. If the phone searches for a signal it is unlocked. I did it with my 4S and an old 3GS.
  6. Applejuiced macrumors Westmere


    Apr 16, 2008
    At the iPhone hacks section.
    Wish it was that easy but its nowhere as simple.
    Give it a try anyway and see how far you get.
    Without shsh blobs there's no way to restore to older firmware not signed by apple any more.
    And on the 4S its 10 times harder even if you did have those blobs saved.
  7. jent thread starter macrumors 6502a


    Mar 31, 2010
    Can you speak more to this? I have a non-AT&T SIM, my locked iPhone 4S, and an unlocked iPhone 4, and with the non-AT&T SIM in the unlocked iPhone it says "Searching…" while it says "No Service" on the locked iPhone, despite AT&T flagging it for unlock.

    I'm fairly confident it indeed needs to be restored via iTunes, despite your claim that there is no need to do a restore.
  8. KoukiFC3S macrumors 6502a

    Jul 4, 2010
    This. Try resetting your network settings too.
  9. Applejuiced macrumors Westmere


    Apr 16, 2008
    At the iPhone hacks section.
    Try a erase all content and then plug in to itunes to activate it.
  10. Baggio macrumors 6502

    Oct 18, 2012
    I didn't have to do it on my 4S or my 3GS. Already tested with different SIM cards.

    In an locked phone you are either going to get an invalid SIM error or the connect to iTunes message.

    The problem with testing a different SIM card is related to if that carrier has service in your area, i.e. an active T-Mobile SIM in the US is that it will come up with "no service" if it is a foreign SIM card. Check in Settings>General>About and see if it reads the carrier if it is a foreign SIM.
  11. BFizzzle macrumors 68020


    May 31, 2010
    Austin TX

    just use these steps via redsn0w

    i know its for not loosing your jailbreak..but the same thing applies for you. just put in DFU mode.. click instal jailbreak.. uncheck "install cydia" check deactivate. Connect to itunes to activate.
  12. pixelrogue, Jan 3, 2013
    Last edited: Jan 3, 2013

    pixelrogue macrumors newbie

    Jun 8, 2012
    Need to restore 5.1.1 to iPhone 4S

    Device: Verizon iPhone 4S / Jailbroken / Gevey Ultra S Sim (unlock)

    All - installed a stupid tweak through Cydia and..and... bricked the 4s... nothing but a silver apple logo. Tried everything from restoring a saved .ipsw file (which seems to work until iTunes checks w/the server. Turn off internet... iTunes will not progress because it can't access the servers).

    Yes, I have the blobs saved on the Cydia servers...via TinyUmbrella. Closest I can get is locating the blobs and then getting error message the device ids are not the same. The phone is the same phone, but i have since updated the computer itself. The id would be the phone, right, not the computer?

    So here I am - refusing to update to 6.0 and unable to restore. Tried like mad to get in through (cyberduck, iExplorer etc) to remove the app but nothing... nothing happens. Tried restore through Redsn0w - but all redsn0w functions return messages the 4S is not supported. Blackrain, nor Absinth, recognize the device.

    Any ideas?

    Side question ~ the device was already jailbroken via Redsn0w... why is it kicking a 4S not supported message now when it worked before?

Share This Page