Restoring a 4S backup to an iPhone 4 in ios5?

Discussion in 'iOS 5 and earlier' started by Dellfanboy, Jun 25, 2012.

  1. Dellfanboy macrumors member

    Joined:
    Jun 25, 2010
    #1
    Hello,

    I recently had my 4S stolen and bought an iPhone 4 off craigslist. When I try to restore (on version 5.0.1) I'm getting an error regarding "iPhone could not backup because backup file was corrupt or not compatible". Do I need to upgrade to 5.1.1 in order to do the backup?

    Any advice? I even tried my old iPhone 4 backup from last year and that failed too.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    You need to upgrade your iPhone 4 to the same version of iOS as the backup or a newer version. If the backup is of iOS 5.1.1, you must update the iPhone 4 to iOS 5.1.1. You could even restore that backup onto a 3Gs running iOS 5.1.1.
     
  3. Dellfanboy thread starter macrumors member

    Joined:
    Jun 25, 2010
    #3
    How can I find out what version the backups are?
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    I don't think there is a way to do it via iTunes. You can try one of the various backup extractor utilities to see which version it is.
     
  5. Dellfanboy thread starter macrumors member

    Joined:
    Jun 25, 2010
  6. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
  7. Dellfanboy thread starter macrumors member

    Joined:
    Jun 25, 2010
    #7
    Well quick update. I gave up. Upgraded to 5.1.1. The restore from 5.0.1 is now running. Doesn't make any sense but I'm not complaining. Thanks for your help.
     

Share This Page