Restoring Address Book from Time Machine

Discussion in 'Mac Basics and Help' started by cg75, Apr 28, 2011.

  1. cg75 macrumors newbie

    Joined:
    Feb 28, 2011
    #1
    Hi, I'm using Mac OS X 10.6.7.

    I want to restore my Address Book from Time Machine as some of my contacts are missing in the most recent version of Address Book on my iMac. However, when I restore a past copy of Address Book it has exactly the same list of contacts as the current one...even though I know they were different back then.

    I went into Time Machine, selected the date of the back up I wanted; selected Address Book in Applications; clicked Restore and Keep Both versions of Address Book. But I got two Address Books containing the same (most recent) information.

    If anyone else has had this problem, I would welcome their advice on how to solve it.

    Thank you.
     
  2. discounteggroll macrumors 6502

    discounteggroll

    Joined:
    Aug 6, 2006
    Location:
    Greenwich, CT
    #2
    are you sure you're copying the folder located at:

    Home Folder/Library/Application Support/Address Book

    simply restoring the application will do nothing for you. This is where the "data" for your address book is located
     
  3. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #3
    Open address book and have it the top window, then enter time machine. You will be taken to series of backed up address books. Scroll through them to see which one you want to use (or select individual contacts) and restore. No need to hunt through data files.
     
  4. Jolly Giant macrumors 6502a

    Jolly Giant

    Joined:
    Sep 15, 2010
    Location:
    Hamburg, Germany
    #4
    click here and scroll down to restoring via address book.
     
  5. cg75 thread starter macrumors newbie

    Joined:
    Feb 28, 2011
    #5
    Thank you!

    Thank you for all the replies. jive turkey's solution worked like a dream.

    I did try discounteggroll, but didn't have Address Book in Application Support, so couldn't go any further with this. Although I didn't need to use Jolly Giant's tutorial, I was pleased to be directed to it for any further questions I might have with Time Machine.
     
  6. Psychotech macrumors newbie

    Joined:
    Sep 25, 2009
    #6
    Thanks! worked fine


    After failing to try and just restore the addy book, which don't work.
     

Share This Page