Restoring Factory Settings HELP!

Discussion in 'Jailbreaks and iOS Hacks' started by mac417, Feb 9, 2008.

  1. mac417 macrumors newbie

    Joined:
    Nov 7, 2007
    #1
    Let me give you the whole story... Okay here we go:

    I bought an iPhone the first day they came out. I then waited months and months for an unlock. I paid the $50 dollars for IPSF (iPhone Sim Free) and unlocked my phone for T-Mobile with that. I have left my phone the way it was since then using T-Mobile and software version 1.0.2 being scared to mess anything up if I updated my software version. My service agreement with T-Mobile ended in January so I switched to AT&T. I had my number transferred to my new "free" phone with AT&T at which point my iPhone with my T-Mobile card still in it said "No Service". I tried to put my new 3G simcard from my new phone into the iPhone but it says "Incorrect Sim Connect to iTunes". I connected to iTunes and tried to activate it like a new iPhone and went through all the steps but on the last step when it was activating it iTunes said it couldn't do it and to try at a later time. Weird thing is I put my friends Cingular card in my iPhone before and it worked just fine but now it says "Incorrect Sim". Anyhow now I just figure restore everything back to factory and sign up with AT&T. Can I do that? If so how? Can up unlock it with anything else? I was also thinking about upgrading to the new 16gb model..... can I with my phone if I restore it back to factory? Please any feedback would be very helpful.
     
  2. mac417 thread starter macrumors newbie

    Joined:
    Nov 7, 2007
    #2
    I changed my account and everything over to an iPhone account and it sent me an email saying "Congratulations, AT&T has successfully activated your iPhone service.


    If you have not done so already, please connect your iPhone to your computer now to complete this activation.

    When I do iTunes says "The iPhone could not be activated because the activation information was invalid. Please try again later."

    Please can anyone out there help me and tell me what I need to do?
     
  3. mac417 thread starter macrumors newbie

    Joined:
    Nov 7, 2007
    #3
    All I did was Updated the new software and it's worked! So for anyone else in the same situation just update and you'll be fine.... as long as you're with AT&T. If not then you'll have to use a jailbreaker, etc.
     

Share This Page