restoring firmware to Imac: had problems getting CD to read, any suggestions?

Discussion in 'Mac Basics and Help' started by maxmacaddict, Apr 2, 2010.

  1. maxmacaddict macrumors newbie

    Joined:
    Mar 28, 2010
    #1
    OK, taking another look at my booting problem (where the computer sees neither optical nor hard drive, though both work perfectly fine in target mode):

    It has now become apparent that a firmware upgrade was started on this machine (before I got it) and it was corrupted. For example, all conventional keyboard commands in start up mode (open firmware, c key, option key to select drives) do not work.

    so I downloaded (from Apple) the "firmware restore cd 1.4 for Imac 5,1" (my machine) and happily set about to install it thinking i had the solution to my problem. Followed instructions exactly (burning the .dmg to a cd disk, inserting with power button held to trigger firmware update/install mode). Computer went into firmware update/install mode but -- refused to spin the disk in the drive! just "ca-chunk ca-chunk" ad infinitum.

    Of course i want to fix this myself, not pay apple $800 or so (assuming it is fixable). Any suggestions on how to get this firmware restore CD to load? Alternatively -- will the computer automatically boot from an external firewire drive even though it sees no other disks? (certainly works fine when in target mode)

    Please contribute your experience!!
     
  2. fullojellybeans macrumors regular

    Joined:
    Mar 31, 2010
    #2
    either the main board is shot or the hard drive is causing the booting issue. unfortunely the hard drive in the iMac is not user removable so it's gonna be hard to troubleshoot it.

    Could also be something small like a flex cable
    take it to a store and let them mess with it preferably they'll help you out
     
  3. maxmacaddict thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #3
    re: firmware --- hard drive not the issue

    i replaced the hard drive (not easy to get to but i did) and the new hard drive (which now has Tiger on it) boots fine when accessed in target mode from a powerbook g4 that i have. this is why it is so strange: the logic board works perfectly fine either as a target disk or as the host to the powerbook!

    if anyone can suggest a reason why the firmware install won't work i would like to hear your experience.
     
  4. maxmacaddict thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #4
    Solved Imac booting problem

    For the benefit of others who may encounter this problem (Imac Core Duo 2.16 ghz would not recognize hard drive, would not boot to optical drive from "C", etc.) I solved the problem and here is how.

    I used "SuperDuper" (downloadable free) to copy my HD (Tiger OSX) from a PowerBook G4 to the HD on the Imac. To access the Imac hard drive, I connected the Imac to the PowerBook with the Imac in "target" mode (boot with the "T" key depressed). . In target mode (firewire connection required) I could access the Imac HD (for copying purposes) from the PowerBook screen. Then used SuperDuper to copy the Powerbook start-up disk to the Imac HD.

    After the Tiger was loaded on the Imac drive, the Imac recognized the drive and would boot to the drive -- however , all functions don't work properly because the Imac requires Snow Leopard (since it has the Intel chip) . So I then purchased Snow Leopard (ebay) and loaded that onto the Imac, and presto -- Imac booted, recognized all drives, and firmware key combos appear to work as normal. All systems are operational.

    Side note -- if you are having problems with Imac Firewire drive, as I did, this seems to work: unplug the Imac for fifteen seconds (resets the power unit); boot with pram clear key combo (option/command/p/r keys depressed together and held down) till you hear the chime repeat three times. Appears to reset the firewire ports.

    So it can be done. For some reason, I never could get the Apple provided firmware restore CD to load on the Imac properly.
     

Share This Page