Restoring from encrypted TM backup

Discussion in 'Mac Basics and Help' started by cupcakes2000, Apr 26, 2017.

  1. cupcakes2000 macrumors 6502

    Joined:
    Apr 13, 2010
    #1
    Hi!


    As the title says, I'm trying to use disk utility to restore from time machine back up but the keyboard won't type into the encrypted time machine back up password field!


    It's so weird and so extremely frustrating. The keyboard obviously works, as I used apple key R to get in to recovery mode.


    Any ideas? I really don't want to spend a week decrypting this disk, restoring and then re encrypting. This is the only option I can see, but that's just ridiculous.


    Its a 2010 MBP 17" running newest Sierra 10.12.5 beta


    The time machine back up is from my main computer 2014 5K27" iMac running same OS.


    I always do this, I keep my laptop at a different location and periodically sync them in this manor. Only this time it doesn't work.


    Arghhhhhhhhhh!

    Any suggestions??
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #2
    Where are you booting from? Does the keyboard not work at all?
     
  3. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #3
    Booting from a usb disk, Keyboard works fine when machine is on, and MUST be working to enter restore mode. Just nothing happens when I try to enter a password.


    ***** edit, Sorry.. booting from internal drive, misread the question *******
    --- Post Merged, Apr 26, 2017 ---
    Screenshot:
     

    Attached Files:

    • look.jpg
      look.jpg
      File size:
      579.1 KB
      Views:
      35
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    Bluetooth keyboard? Can you get into Disk Utility or Terminal?
     
  5. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #5
    No, MacBook Pro.

    Disk utility yes, only TM partition is greyed out.

    Terminal, no. I'm pretty sure I should be able to form the menu bar but there is no option. Just startup disk, restart and shut down.
     
  6. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #6
    Greyed-out means that it is not mounted. You can unlock it with Disk Utility too.
     
  7. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #7
    Ah yes, I realised that shortly after I wrote it. However, it won't mount without being unlocked, the keyboard won't type in the field within disk utility either. Also, the password field doesn't work whilst trying to enter a wifi password either.

    I'm finding this really strange.
     
  8. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #8
    I am still not sure which environment you are actually booted in (Recovery or Internet Recovery). Have you tried booting into the Time Machine disk directly?
     
  9. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #9
    Im booted into the recovery partition on the internal Hard disk.

    From this mode, I can't use the keyboard to enter any password fields, either to unlock the time machine disk, or to enter wifi code.
    This is true whether I try to revert to time machine by the standard mechanism on the main page, or via disk utility, or if I try to boot from another startup disk.

    The keyboard is built in, works perfectly when booted, and must work in order to hold down the Apple Key and R to get into recovery mode.

    From memory on this recovery page, there used to be a top menu bar which (amongst many other options) gave you the option of terminal. For some reason, this is no longer here.
    The apple logo gives me: start up disk, restart, and shut down. The name next to that is 'Language chooser' (or something to that affect, I'm not there right now).

    So if you, or anyone has any ideas on this it would be really great!
     
  10. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #10
    OP wrote:
    "Arghhhhhhhhhh!
    Any suggestions??"


    Yep.
    NEXT TIME, don't encrypt your backup.

    The whole purpose of a backup is to make it easy to "get back, get back, get back to where you once belonged" in a moment of extreme need.

    When you deliberately put up roadblocks to doing so, it ain't so easy.
    Just as you're discovering now…

    Addendum:
    Also for next time, try either CarbonCopyCloner or SuperDuper and create a bootable cloned backup instead.
    In that case, if you need to restore, you do this:
    1. BOOT from the backup
    2. Re-initialize internal drive
    3. RE-clone the cloned backup BACK TO the internal drive.
     
  11. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #11
    I did a quick web search and it seems that other people have had this problem. I am not sure what you can do about it. Perhaps an external keyboard may work.

    I have also found that Recovery is buggy since Sierra. I have experienced the missing menu bar too. Terminal should be there. Can you create a Sierra installer drive and boot from there? See also here for some suggestions, maybe something works.

    I always thought backups were meant for, you know, backing up files.
     
  12. cupcakes2000, Apr 27, 2017
    Last edited: Apr 27, 2017

    cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #12
    I don't mean to be rude but what a ridiculous concept!! Take the trouble to encrypt your internal system disk, don't encrypt your external and therefore infinitely more stealable backup disk. Literally defies the entire point.

    The problem isn't that the disk is encrypted. The problem is that the password fields in recovery mode are unresponsive. I would suggest the problem is due to the fact I'm using a beta OS - but I can't help myself!

    I have always synced the two machines in this manor every few months, never had a problem before.
    It wouldn't make any difference if I went with your suggestion of CCC or something, it would still be encrypted, as it would be a clone of an encrypted drive, and so I would still be in he same boat anyway - the problem is I can't enter any passwords for some reason.

    Ok I'll try an external keyboard, have to find a wired one form somewhere, Bluetooth isn't available either in this weird 'limited' recovery mode.

    I'll try to create a bootable installer if that doesn't work.

    Recovery mode on my iMac works as normal, exactly the same version as the problem machine.

    Thanks for the advice.
     
  13. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #13
    **UPDATE**

    I made a bootable USB, as recommended - Thanks! I restarted with option, and it jigged the OS into starting up with the PROPER RECOVERY MODE!!!!

    All is well and I am restoring with no issues.

    Oh my god. What a massive pain in the ass. Thanks for your help KALLT!
     
  14. fulles2000 macrumors newbie

    Joined:
    May 17, 2015
    #14
    Just incase anyone else comes across this the way I solved it was to boot the machine into recovery mode ensuring that you have an external keyboard connected prior to booting.

    It may have been a fluke but this was the only thing that worked for me. USB boot did not solve it for me.
     

Share This Page