Restoring iPhone 4 Help.

Discussion in 'Jailbreaks and iOS Hacks' started by SiHi, Jun 18, 2011.

  1. SiHi, Jun 18, 2011
    Last edited: Jun 18, 2011

    SiHi macrumors newbie

    Joined:
    Feb 11, 2010
    #1
    SUMMARY:

    iPhone 4 unlocked Bell Canada
    4.2.1. tethered jailbreak (redsn0w 0.9.7b6)
    tried to jailbreak using 4.3.3. ipsw instead.
    _____________________________
    stuck with "plug into itunes" image.
    Error 1013 when restoring to 4.2.1 through iTunes.
    iPhone not eligible for requested build restoring to 4.3.3.


    I've been following various guides for days, getting close but not quite there. I know there are hundreds of these topics, but I didn't want to risk making things worse.

    I'm fine with erasing anything I might have to, got my phone only recently.

    Please help.
    Thanks. :(

    Edit:

    LOL. After two weeks trying to fix this doing everything I could find/think of, I tried restoring the apple way, through itunes, on a new computer and it worked first try.

    Mods, feel free to delete this post or lock it and leave it for other people with this problem.

    Thanks anyway guys :).
     
  2. nebo1ss macrumors 68030

    Joined:
    Jun 2, 2010
    #2
    The reason the new computer works and not the old is because Tiny umbrella changed your host file. On original computer open Tiny Umbrella, go to advance mode, uncheck box that says " Leave host file to Cydia on exit" close Tiny umbrella. You will have no further problems.

    A simple explanation of problem is that with host file pointing to Cydia, firmware signing is simulated by Cydia. However, Cydia not capable of signing baseband which causes failure and the error code you see.
     

Share This Page