Restoring my phone/Cydia

Discussion in 'Jailbreaks and iOS Hacks' started by ofest, Nov 15, 2010.

  1. ofest macrumors newbie

    Joined:
    Nov 15, 2010
    #1
    Thanks for reading and I hope you can help.

    I have a 3G iphone. Initially was on 3.0 which was JB and unlocked through Blackra1n. I upgraded it to 4.1 (8B117) using redsnow. Didn't work for some reason (missed something in the dfu instructions) so I tried to load 3.1.2 back using Blackra1n. Since then I am playing with the phone and not knowing how to make it work properly again.

    I am trying to get 3.1.2 (7D11) to work. Model is MBO46LL with modem 05.11.07

    The problem is that I have no Cydia after I run Blackra1n or Redsnow. If I run Blackra1n, I get the unlock (can make calls) but no GPS, no Cydia (or rock), no youtube. If I run Redsnow, I get the gps (sometimes) but Cydia is dead so no unlcok.

    Cydia basically tells me it failed to fetch these:

    http://repo.smxy.org/cydia/apt/dists/xena/Release.gpg
    http://repo.smxy.org/cydia/apt/dists...slation-en.bz2
    http://repo.smxy.org/cydia/apt/dists...s-arm/Packages

    All three end with the message "NetDB Open nodename nor servname provided, or not known" and at the bottom it says that some index files failed to download, they have been ignored, or old ones used instead.

    After the message I get "Reloading Data" that never ends.

    The good thing with redsnow is that it allowed me to get to the root through DiskAid. I cleaned some files in lists (/var/lib/apt/lists) except for the folder called partial. I also looked at /VAR/LIB/DPKG/UPDATES (there was nothing there) and /etc/apt/sources/cydia (nothing there as well). All this didn't fix Cydia.

    Hope this was detailed enough, please let me know if you need more input from me and thanks in advance for the help.
     
  2. ofest thread starter macrumors newbie

    Joined:
    Nov 15, 2010
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    Restore it to 3.x.x firmware (no hashes needed) then choose set up as new.
    Make sure everything works by testing, then re-jailbreak if you want.
     

Share This Page