Restoring the EFI to original?

Discussion in 'MacBook Pro' started by cal296, Oct 14, 2015.

  1. cal296 macrumors newbie

    Joined:
    Mar 22, 2014
    #1
    Hello,

    I have a MacBook mid-2010 running OS X 10.11, and I decided to use a hack to get the bootup screen to be black like it is on newer laptops.

    It didn't work, my bootup screen hasn't changed. But now the laptop is acting strange and I'm wondering if it is down to this EFI hack I did...?

    Basically I need a way to restore what ever I did to the EFI, it was a .command file I ran and it doesn't come with a way to reverse what it did.

    Reinstalling the OS is the last option :/

    Thanks
     
  2. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #2
    i don't recall installing os x have anything to do with firmware.

    is it possible that the command you ran just wrote something to nvram and not the bios? so you can just reset pram??

    you have to go to apple downloads and download the latest EFI file for your computer
     
  3. BrettApple macrumors 65816

    BrettApple

    Joined:
    Apr 3, 2010
    Location:
    Heart of the midwest
    #3
  4. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #4
    From "Step 5":

    In the future, it would be prudent to read and attempt to understand what is really being done to your system when you run any .command script that you download off the internet. This includes any steps necessary to recover in the event of a possible failure of running a script.

    If you deleted the backed up boot.efi, or it doesn't exist for you for some reason, then you will have to reinstall OS X.

    Back things up, reformat, and reinstall, and then restore your data (do not restore settings, as you risk restoring the bad boot.efi image by doing so.)
     
  5. cal296 thread starter macrumors newbie

    Joined:
    Mar 22, 2014
    #5
    Hi guys thanks for your responses :)

    I have tried downloading the correct EFI and SMC firmwares for my Mac but when ever I open them I get a message saying it isn't supported by this computer. I even double checked which ones I was downloading, so thats odd.

    Anyways my problem is solved because after reading the documentation it appears that it doesn't work on OS X 10.11 because of a new feature called 'Rootless'. This basically stops applications from being able to inject code or change code of the EFI. Hence the fact the mod didn't work, and my EFI must be still original.

    I think it must be the new OS X that is making the laptop run strange, I dunno it is getting old.

    Thanks anyways for your help guys.
     

Share This Page