Restoring the VMWare Fusion Icon to the Upper Right on Desktop

Discussion in 'OS X Mavericks (10.9)' started by dgbarar, May 7, 2014.

  1. dgbarar macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ
    #1
    I own a late 15" retina MBP operating under 10.9.2. I was working with Apple today to assist me with Sleep/Wake issues. One of the things they had me do during trouble shooting was eliminate my start-up programs. One of those start-up programs was the VMWare Fusion. But not really.

    In the past, I had the VMFusion (diagonal double headed arrow) in the upper right corner. VMFusion was not running, but I could select what I wanted to do.

    I would like to put the icon back, but the best I have been able to come up ends up launching the VMFusion at start-up. I get the icon back, but as soon as close VMFusion the upper right icon disappears.

    How do I get the VMFusion icon back without having to launch the application?

    Cheers,

    Don Barar
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    Open up VMware Fusion and select any VM. Then, press Command+E to access the VM's settings. Under Applications Menu, make sure that 'Show applications menu in menu bar' is set to 'Always'.
     
  3. dgbarar thread starter macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ
    #3
    Hi V,

    Thanks for writing back. However, the tray icon for VMFusion icon did not return after rebooting the computer.

    Do you have other thoughts?

    Cheers,

    Don
     
  4. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #4
    Config VMFusion like yjchua95 said. Also you should add VMFusion to your Login Items.

    1. Open System Preferences > Users & Groups > Login Items.
    2. Go to Applications folder > drag & drop the VMusion icon into the list of Login Items > check "hide".

    Now when you reboot the arrow icon will show up in your top menu bar. When you close the open VMFusion app the icon remains in you top menu.
     
  5. dgbarar thread starter macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ
    #5
    HI B,

    Thanks for writing. I have attempted this and it does work. But it also launches the application VMFusion at log-in I do not want VMFusion to launch at log-in. I just want the icon to show up so that I can launch VMFusion when I want to.

    Cheers,

    Don
     
  6. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #6
    What's the problem with the log-in startup?
     
  7. dgbarar thread starter macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ
    #7
    Hi B,

    Thanks again for the quick reply.

    If I place VMFusion in the start-up, when I re-boot, I launch the VMFusion application--I also get the tray icon. However, I do not want to launch the application. What I would like to do is upon reboot have the tray icon appear without launching the application.

    Cheers,

    Don
     
  8. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #8
    Use my steps and don't put VMware Fusion into login items.
     
  9. dgbarar thread starter macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ
    #9
    Hi V,

    Did that. But, the tray icon for VMFusion did not return after a re-boot.

    Don
     
  10. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #10
    Oh? That's strange. Mine stayed up there even after a reboot.
     
  11. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #11
    Tried it too, no luck.
     
  12. FreakinEurekan, May 10, 2014
    Last edited: May 10, 2014

    FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #12
    Open Finder - go to Applications - right-click on VMWare Fusion, and select Show Package Contents. From there go to Contents, then Library - then locate VMWare Fusion Start Menu. Drag that into Login items in System Preferences > Users & Groups.
     

    Attached Files:

  13. m4v3r1ck macrumors 68020

    m4v3r1ck

    Joined:
    Nov 2, 2011
    Location:
    The Netherlands
    #13
    Thanks, that worked 100%!!!
     
  14. dgbarar thread starter macrumors regular

    dgbarar

    Joined:
    Feb 27, 2014
    Location:
    Fountain Hills, AZ

Share This Page