Restriction passcode

Discussion in 'Jailbreaks and iOS Hacks' started by snowzor, Jun 17, 2012.

  1. snowzor macrumors newbie

    Joined:
    Jun 5, 2012
    #1
    Hello everyone! I have a big problem. I've inserted a restriction passcode a long time ago, I haven't enabled any restriction and in the meanwhile i forgot the passcode. Now I need it to reset my settings. Is there any way to discover/reset it without factory restore? iPhone 4 iOS 5.1.1 Jb (Absinthe)
     
  2. pixelrogue macrumors newbie

    Joined:
    Jun 8, 2012
    #3
    iPhone Restrictions - phantom password

    All - this has happened a few times over the years (various iPhone models and iOS versions)

    Something happens and I discover the restrictions password locked down. What is interesting is that I NEVER even played w/restrictions... never even opened the menu or set the password. Apple insists this action happens as a result of a user setting the password and I can tell you that is not always the case.

    Used to be able to get the password (which, again, looks like a random string I never set), and used to also be able to go in and 'add' a password allowing me then to unlock and turn off (both on the com.apple.springboard.plist). Neither method now appear to work in 5.1.1.

    Problem One: How to PREVENT this from happening? Have no idea how this happens.

    Problem Two: Gaining Access.

    Anyone w/similar stories?
     
  3. rrandyy macrumors 6502

    Joined:
    Jan 14, 2009
    #4

    I'm not convinced it is randomly setting a password. However, I suppose you could set a pass code once you restore so that at least you will know it. No idea how to address problem 2.
     
  4. seanwebb68 macrumors 6502

    Joined:
    Jul 27, 2010
    #5
    So what you need to reset passcode for iPhone/Pad with iOS 5.0.1

    iOS version 5.0.1 (I think that this will work with 5.0)
    Jailbroken device (don't know if this is a requirement)
    iFunbox
    Firefox with SQLite Manager plug-in
    iFile app on your device

    You must to do next steps

    connect your device to PC
    open iFile on your device
    open file /User/Library/Preferences/com.apple.sprinboard.plist
    switch off SBParentalControlsEnabled
    open i-FunBox on PC
    go to Raw File System/Library/Keychains
    download keychain-2.db file to the PC
    open FireFox and then from the tools menu open SQLite Manager
    in SQLite Manager open previously stored keychain-2.db
    select table genp
    find the row with value com.apple.preferences in agrp column (It is not shown - I already deleted it. I had only one row with this value, so be carefully)
    and delete it
    save this DB in SQLite manager
    via i-FunBox upload file keychain-2.db
    to the Raw File System/Library/Keychains
    All done - your passcode have been removed.

    Let me know if you have any problems
     
  5. amaksoud macrumors newbie

    Joined:
    Jul 21, 2012
    #6
    I tried this before on 2 different iPhones, one jailbroken and the other is not.

    For the jailbroken one, I tried the above steps except that I didn't open iFile and i didn't use anything to set the SBParentalControlsEnabled to false.

    It worked like a charm.

    When I tried yesterday to do the same for a non jailbroken iPhone, I was able to connect but I was not able to see the folder /library/keychains.

    Any clues on how to remove it without jailbreaking the phone ?
     

Share This Page