Retail XP install on Boot Camp partition hangs

Discussion in 'Windows, Linux & Others on the Mac' started by MacSchwigg, Mar 3, 2008.

  1. MacSchwigg macrumors newbie

    Joined:
    Feb 12, 2008
    #1
    Hello, all.

    My Penryn MBP finally arrived! One of the first things I've tried to do is partition my drive and install XP to switch back and forth for gaming and a couple other applications. I've run into a snag, though, and I'm wondering if anyone has had a similar experience and found a solution.

    The Boot Camp partition process seems to run without a hitch - I created a 32Gb partition and was prompted for the Windows Install disc. I'm trying to use a Windows XP Pro disc that I bought retail from Circuit City in Mar 2005 - I'm assuming it's SP2... right?

    My install disc identifies all the partitions and I select the 32Gb option and select FAT32 for the file system, as I'd like to be able to move files back and forth if needbe. The computer then formats, copies files, and reboots.

    I'm then brought to the more "graphical" install screen and told that I have 39 minutes remaining in my installation. The tips continue to cycle on the right side of the screen, but at this point, progress stops. The CD is spinning in the drive, the computer is getting pretty hot, but nothing is happening. I had to do a hard reboot, eject the CD, delete the partition, and start over. I've tried this twice now with similar results.

    Am I missing something here? Has anyone run into this problem before and been able to get beyond it? Thanks for any advice.
     
  2. MacSchwigg thread starter macrumors newbie

    Joined:
    Feb 12, 2008
    #2
    I believe I was able to get beyond the disc issues last night. Doing some more sleuthing around the forums here, I caught word of a program called nLite (www.nliteos.com) and used it to make a slipstream version of my Windows XP disc with SP2. Again, I could have sworn that this disc was already SP2, but the program didn't complain and I burned a new disc using the ISO nLine generated. This installation appeared to go smoothly.

    I ran into plenty of other problems after that, but I'll save those for another day and another thread.
     
  3. Jpoon macrumors 6502

    Joined:
    Feb 26, 2008
    Location:
    Los Angeles
    #3
    I was actually having a similar problem, but I can't really pinpoint the reason. Just tried it again, and it worked. I think it's just buggy :(.
     
  4. Flowero4ka macrumors regular

    Joined:
    Jan 24, 2008
    #4
    Maybe you'll try running windows simultaneously with mac, using NOT bootcamp?
     
  5. Neil321 macrumors 68040

    Neil321

    Joined:
    Nov 6, 2007
    Location:
    Britain, Avatar Created By Bartelby
    #5
  6. Roadking macrumors 6502

    Joined:
    Feb 27, 2008
    #6

    I am having problems with my install disc now too. Mine hung up with only 6 minutes left to go. Then experienced the same problems you were having.

    I shut it off and rebooted it to no avail. The next time it wouldn't do anything and had the same 39 min remaining.

    I tried to repair the file but that didn't work.

    I finally had to hit the track pad button to eject the disc that wanted to keep on booting the OS.

    Now I am back on Leopard. I see an icon on the destop that says unknown. I alloted 32 GB for bootcamp and that is showing that it has been removed from the total allocated HD.

    How do I resume the installation and hopefully pick up where the installation left off? Any suggestions? Thanks.
     
  7. MrBungleBear macrumors newbie

    Joined:
    May 1, 2008
    Location:
    UK
    #7
    XP Install to bootcamp hand on MacBook Pro

    Got my shiny new 15" MBP yesterday, got it all set up and ready to roll. All was going well (except you apparently can't spoof wired en0 MAC addresses - Leopard drivers not up to it for the MBP NICs) until...

    So, on my MacPro, bootcamp works fine, XP Pro SP2 is installed and working fine in dualboot, although I usually use it via parallels.

    On my MBP, though, the setup part of the install hangs. The pointer disappears shortly before the screen where you set your keyboard & language settings, etc, and the install hangs there. It starts the setup saying it will take about 39 mins, and it still says 33 mins when it finally hangs.

    Windows PoS!

    The first time I tried this, I left it overnight and came back to it frozen even before that setup screen, just still running thru the "sales pitch" stuff, with the little green squares still making it look like there is progress, but no dice - that was after about 4 hours! (I need to get more sleep).

    Next times, it got to the setup screen, but you can't do anything. Tried it with a USB mouse, too, but I think this is before any USB drivers are present - whatever: it didn't help.

    I'm gonna delete the whole partition and try again today and I'll let you know.

    Has anyone seen anything like this and got past it to get a successful XP Pro install?

    G>
     

Share This Page