Retina Macbook - Jumpy / erratic cursor

Discussion in 'MacBook' started by ctyrider, Oct 18, 2015.

  1. scarecrow81 macrumors newbie

    Joined:
    Oct 4, 2015
    #26
    I too have experienced this issue on the new macbook and I am convinced it is my thumb causing the issue. I have found while sitting at a desk, raising the back of the macbook about and inch and a half forces me to change hand position while typing and the issue disappears. Yes, disabling tap to click takes care of it too, but one hates to give that up.
     
  2. thesyntaxinator macrumors newbie

    Joined:
    Oct 23, 2016
    #27
    I made a program to disable the trackpad for a short time whenever a keyboard key is pressed. It's worked well for me on El Capitan so far -- hopefully it helps some of you as well: https://github.com/thesyntaxinator/TouchGuard
     
  3. McRumour, Dec 16, 2018
    Last edited: Dec 16, 2018

    McRumour macrumors regular

    Joined:
    Oct 6, 2013
    #28
    OMG! I've been plagued and tormented by issue of erratic, maniacal jumping of my cursor on my mid-2015 retina MBP ever since its initial boot-up in 2017.
    Cannot believe something as simple as turning off tap to click in System Preferences appears to have solved my agony.

    Will your "fix" work with Mojave 10.14.2?
    Ideally, I'd hope to be able to have "tap to click" turned on, but automatically turn off only when I'm typing and then turn itself back on again.

    Thanks

    update: Just realised I'm in MacBook forum.
    I actually have a MacBook Pro - but the issue seems the same. And now that I see turning off "tap to click" has stopped the spastic cursor behaviour - I'm even more anxious to receive a reply to my query above.
     

Share This Page