Retina MacBook Pro - No System Sounds from Internal Speakers

Discussion in 'MacBook Pro' started by g-boac, Nov 25, 2012.

  1. g-boac macrumors 6502

    Joined:
    Oct 7, 2007
    #1
    I have a 15" Retina MacBook Pro running OSX Mountain Lion (10.8.2). Recently, I have noticed that it will occasionally stop making system sounds through my internal speakers following wake from sleep.

    Playback from iTunes or Quicktime seems to work fine. So does the volume increase/decrease feedback sound. The problem persists until I reboot, then everything is fine again.

    Here's the oddity. When I plugged in my headphones to listen to a movie on my flight home over the weekend, my computer suddenly started playing ALL of the system sounds that had been saved up. My Mac had been on for several days, and this playback took about 10-15 seconds of dings, sosumis, and swooshes to complete. From that point forward, things are normal, even after I unplug the headphones.

    This same behavior happened again today. I noticed that the system sounds had stopped (no crumple when emptying trash; no sent mail swoosh or iMessage pop, no camera shutter release sound when taking a screen shot) so I plugged in my headphones and my machine made all the sounds from the past several hours through the headphones. Again, things were fine from this point forward, whether I continued using the headphones, or unplugged and used the internal speakers.

    Any ideas for things I can try deleting or resetting (corrupt preference files, etc) in an effort to fix this?

    Thanks!
    Mark
     
  2. tmanto02 macrumors 65816

    tmanto02

    Joined:
    Jun 5, 2011
    Location:
    Australia
    #2
    My 13" Retina did the same thing the other day! When I heard all the system noises again I thought it fixed its self but now i'm back to no square one.
     

Share This Page