Retina Macbook Pro- Video Corruption on Wake

Discussion in 'MacBook Pro' started by thebritishguy, Jul 4, 2012.

  1. thebritishguy, Jul 4, 2012
    Last edited: Jul 4, 2012

    thebritishguy macrumors member

    Joined:
    Dec 30, 2011
    #1
    Hi All

    I have the 2.6/8/512 RMBP.

    Around 50% of the time when it wakes up from sleep (lid shut then open) I am seeing massive video corruption on applications across the board including Mail, Safari, office Etc. Anyone else experiencing this?

    The screen is set to "Retina" i.e. 1920 x 1200 HiDPI

    A reboot fixes the issue but this is becoming very annoying

    thanks

    TBG
     

    Attached Files:

  2. katmeef macrumors 6502

    Joined:
    Jul 20, 2010
    #2
    I have the same model and mine has never done that... Drop it like it's hot and return it for another!
     
  3. astrorider macrumors 6502

    Joined:
    Sep 25, 2008
    #3
    I've had a few times in the past week that something like what you're describing has happened. I hadn't traced it back to happening after sleep though. I just figured there will be a video update hopefully soon that'll take care of it. A reboot sets things straight.

    BTW, your mail icon is calling out for help :D
     
  4. katmeef macrumors 6502

    Joined:
    Jul 20, 2010
    #4
    Have you guys run the apple hardware test? Maybe there's some corrupt graphics memory causing it intermittently.

    I've run the extended test a few times and everything came out ok
     
  5. NewbieCanada macrumors 68030

    Joined:
    Oct 9, 2007
    #5
    I've experienced it too. Rather than reboot though, I just change the resolution with SwitchResX - fixes it right up.
     
  6. stevelam macrumors 65816

    Joined:
    Nov 4, 2010
    #6
    That hardly sounds like a fix. Sounds like these are some buggy machines.
     
  7. astrorider macrumors 6502

    Joined:
    Sep 25, 2008
    #7
    Very helpful :rolleyes: Bleeding edge tech's not for everyone. Feel free to wait a couple generations.
     
  8. bioyuki macrumors member

    Joined:
    Jun 12, 2012
    #8
    I've seen this issue across a bunch of devices, not just the rMBP. It'd happen to my mid 2010 and early 2011 MBPs as well.
     
  9. kdoug macrumors 6502a

    kdoug

    Joined:
    Jun 2, 2010
    Location:
    Iowa City, IA USA
    #9
    I wanted to bump an older thread but this has happened to me twice when waking the computer. I've had the rMBP for only a couple of days now. I'm sure it's a software glitch that should be fixed with an update.
     

Share This Page