Retina macbook SD card reading issues

Discussion in 'MacBook' started by josh bear, Apr 17, 2016.

  1. josh bear macrumors regular

    Joined:
    Jan 11, 2010
    #1
    Hi all,

    Just noticed some strange behaviour on my mac book and would appreciate any help.

    I placed an SD card from my camera into a USB 3 SD card reader which was plugged into the apple power / HDMI / USB - usb c connector. Nothing happened. Photos did not open and the card did not appear on the desk top.

    I moved the exact same card in the exact same card reader to a USB port on my iMac and photos opened and the card showed up. I then tried the apple single usb to usb -c adaptor and plugged the sd card reader and card into that. Same issue with the card.

    Finally I tried a third party usb to usb-c adapter and plugged the card reader and card into the macbook and photos opened and the card appeared on the desktop.

    So why would a third party connector work but the apple ones wouldn't.

    Thanks

    Josh
     
  2. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
  3. josh bear thread starter macrumors regular

    Joined:
    Jan 11, 2010
    #3
    update. Just used the apple three way adapter with a usb HD and that doesn't show either
    hi, thanks. but I have two from apple and neither worked.
     
  4. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #4
    That's a rather key bit of info to forget to mention.

    The best help is achieved by stating ALL relevant facts when asking for assistance.
     
  5. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #5
    Did you try rebooting while leaving the card reader connected?
     
  6. josh bear thread starter macrumors regular

    Joined:
    Jan 11, 2010
    #6
    Hi deedawg

    It was stated in my description i.e. where i talked about using the apple power / HDMI / USB - usb c connector then the apple single usb to usb -c adaptor

    Boast - thanks for the suggestion just tried that and it worked. Thanks

    Josh
     
  7. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #7
    Whoops, I guess you did, although it was not at all clear. I completely missed the differentiation and thought you were talking about trying the first one again in the iMac.
     

Share This Page