Retrieving all Gmail messages on Iphone 4

Discussion in 'iPhone Tips, Help and Troubleshooting' started by groundeddreams, Dec 14, 2010.

  1. groundeddreams macrumors newbie

    Joined:
    Aug 11, 2010
    Location:
    UK
    #1
    I have setup my iphone4 through the Exchange Account setting, to collect my gmail messages.
    All works fine for sending/receiving emails except for the amount of mails shows in the folders.
    Does not matter which folder I check, it will only show emails that I have in that folder that were received within the last few days.
    So for example, if I log into gmail normally on a PC it will show 50 emails in my inbox, with 2 within the last two days. If I login on my iphone it will ONLY show the 2 emails received in the last 2 days,
    This has always been the case, and I have tried recreating the exchange account and also changed the settings to show "200 Recent messages" but nothing changes.
    I have got a friend to check on his iphone and get the exact same result.

    Anyone know how to expand the viewable emails to show everything, when I go into the Inbox or any other Folders?
     
  2. jplusc macrumors 6502a

    Joined:
    Jul 5, 2010
    #2
    I would love to know about this as well. I don't setup my gmail via exchange for this reason alone.
     
  3. mstrze, Dec 14, 2010
    Last edited: Dec 14, 2010

    mstrze macrumors 68000

    Joined:
    Nov 6, 2009
    #3
    I don't have this issue.

    I only have my gmail account linked to my iPhone's Mail program and I display generally 25-30 of the most recent emails...with the oldest curretly from last Wednesday (today is Tuesday).

    I also have a Load More Messages link on the bottom and it lists that I have 4038 messages total. Pressing this gets me an additional 25-30 more messages.

    I have a 3G...maybe that's the difference? I am running iOS 4.2.

    EDIT: Is 'Exchange" different than just setting it up through the iPhone's Mail App? I did it thorugh the App with no issues at all.
     
  4. poisonvenom macrumors newbie

    Joined:
    Dec 14, 2010
    #4
    done this!

    go to: SETTINGS, then, MAIL,CONTACTS,CALENDARS, then choose your Gmail Exchange account, then MAIL DAYS TO SYNC, and set to NO LIMIT! done... all emails downloaded!
     
  5. groundeddreams thread starter macrumors newbie

    Joined:
    Aug 11, 2010
    Location:
    UK

Share This Page