iPhone RetroArch - PSX games causing crash

Discussion in 'Jailbreaks and iOS Hacks' started by dannyg86, Nov 3, 2014.

  1. dannyg86, Nov 3, 2014
    Last edited: Nov 3, 2014

    dannyg86 macrumors regular

    dannyg86

    Joined:
    Apr 11, 2014
    #1
    Has anyone else had any success with getting PSX games to work on Retro Arch on iOS 8.1 (Jailbroken)? Notes for people, don't install RetroArch from the built in Zottd repo, add the following (official) repo to get the latest version of RetroArch, directly from the team: http://www.libretro.com/cydia

    (PS: I plan on creating a RetroArch guide topic, once I figure out this PSX issue, with your help, as I have figured out a lot of issues already and jumped through a lot of hoops, and want to help everyone with this)

    I had a similar issue with N64 games crashing the emulator upon trying to load them, but this ended up being a file permissions issue, unfortunately the PSX side of things isn't so easily fixed.

    Mednafen (PSX) complains that it "Can't load content", whilst PCSX reARMed just crashes instantly (crashes RetroArch) the moment after you choose a game. I'm using my own games, Crash bandicoot 1 and 3, and Final Fantasy VII. These are taken from disc by myself and work on desktop PSX emulators, so they are working files.

    Using cue/bin and also .img format games, none fair any better. The only success I have had is using the PCSX interpreter core which does actually work, but naturally is a bit slow due to having no Dynarec.

    Anyone got Mednafen (PSX) or PCSX ReARMed working (without using the Interpreter core) yet? If so, how did you resolve the crash on load?

    PS: The log files aren't of much help. Stdout doesn't report anything related, and the PCSX log file's last line is "Init Dynarec" so I am assuming it's having trouble doing that. I have contributed to emulator development in the past (worked on a few PSP emulators, including releasing SNES9x Euphoria and some work on Daedalus PSP)... but don't have time to get my hands dirty and look into fixing this myself at source level right now (if the issue goes that deep).

    EDIT: Managed to get one game working by including scph5001.bin (bios file). I had 1001, 5500, 5502 and 7502 but was missing 5001. That gets crash bandicoot working on Mednafen, the other games still don't work on the former or PCSX though (neither does Crash bandicoot). I'll keep digging..

    EDIT 2: Seems like the PCSX reARMed dynarec is broken on 64bit devices (from some googling on the retroarch board). Still doesn't explain the Mednafen issues... hmm

    EDIT 3: Ironically enough, the PCSX interpreter core is faster than Mednafen. So maybe Mednafen is using an interpreter core too, idk. All the games work on the interpreter core, it's a tad slow (some audio skips) but playable. Guess i'll have to look into the Retro Arch source for PCSX and see if I can figure out why the Dynarec is broken on 64 bit devices, time is the problem :)


    Thanks!
     
  2. forgott macrumors newbie

    Joined:
    Sep 16, 2014
    #2
    Any good news?

    I've tried to solve this with every single configuration so far, but I'm really struggling with it.

    6 Plus here, and always crashing for PSX games.
     

Share This Page