returned my iphone 4 back to 3GS + 1 question

Discussion in 'iPhone' started by PUCCY, Jul 24, 2010.

  1. PUCCY macrumors regular

    Joined:
    Feb 18, 2008
    #1
    So since tomorrow is my last day to return the phone i ended up returning it today. Now i am back to my 3GS. Anyway, shall I update to the 4.1 or stay at 3.1.3?
    Are people having problems with that? or does it work fine?

    If i do experience problems can I go back to 3.1.3?

    Im sorry if this was asked before, I tried to search for the answers on here with no luck.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    I'm assuming you mean 4.0.1. I'd suggest staying on 3.1.3, because once you upgrade you cannot go back without your SHSH blobs (which I don't think you have). Also you may not want to restore your 3Gs from a backup of your 4. It could really screw things up. At least until you get 4.0.1 on it.
     
  3. ClutchThese macrumors 65816

    ClutchThese

    Joined:
    Jun 25, 2010
    Location:
    Alexandria, VA
    #3
    you wont have any problems with a 3GS...

    the only thing is if you upgrade without shsh saved, you wont be able to jailbreak until the new jailbreakis released.

    since you are currently on 3.1.3,(Edit: if youre on the old bootrom) you can jailbreak and do a custom 4.0 to upgrade and be jailbroken. :) i hope this helps you.
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    That's if his/her iPhone is old bootrom.
     
  5. trekkie604 macrumors 65816

    trekkie604

    Joined:
    Feb 25, 2008
    Location:
    Vancouver, Canada
    #5
    I have no problems with 4.0.1 on my 3GS. Multitasking and folders are well worth the install imo. Save your shsh blobs if you want the option of downgrading later.
     
  6. mad-dog-one macrumors 6502

    Joined:
    Aug 14, 2009
  7. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #7
    He can only save his blobs for 4.0.1. Apple isn't signing them for any other versions. But, I do agree save them for 4.0.1. Please don't ask right here, use the search function in the top right of the page.
     
  8. PUCCY thread starter macrumors regular

    Joined:
    Feb 18, 2008
    #8
    its not jailbroken im using ATT but thanks for the answers i'll stay with 3.1.3 then
     

Share This Page