Reverse Latency in Logic 9

Discussion in 'Digital Audio' started by uplift123, Aug 26, 2014.

  1. uplift123, Aug 26, 2014
    Last edited: Aug 26, 2014

    uplift123 macrumors newbie

    Mar 9, 2011
    Hi all,

    I've been having a problem in Logic 9 for a while, now. It affects both external midi instruments and also automation.

    It is although there is reverse latency. The ext. midi instruments are playing early and the automation is heard earlier than it looks on the grid - i.e. if I draw in a plugin to be bypassed on beat 1 of a bar, it will actually turn off nearer beat 4 of the previous bar. Unfortunately it is not dead on a beat, however - so it takes a lot of trial and error to get the timing bang on.

    In terms of the automation - I know that there are the settings in Preferences>Audio>General. I have Sample Accurate Automation set to Volume, Pan, Sends, Plug-in Parameters and I have Plug-in Latency>Compensation set to All : However no adjustment of these settings makes a difference. Could it be something to do with the UAD-2 satellite card?

    With the external midi instruments - I understand that Logic does not delay the midi being sent out for some strange reason. Is there any way to manually adjust for the latency? I use external midi instruments all the time in my projects, often using them well into the later stages of the projects when I have a lot of plugins in use and so a lot of latency is induced. Turning all the plugins off to reduce latency isn't ideal either because the sound of the synth I want to record in will depend on the mix, obviously, which will depend on the plugins. I often resort to bouncing the mix, and recording in a new project - which again, is not ideal.

    Your help will be much appreciated!!


    Mac Pro; OS X 10.6.7; Logic 9.8.1; Apogee Ensemble; UAD-2; Universal Audio LA-610; E-Magic MT-4
  2. koban4max macrumors 68000

    Aug 23, 2011
    could it be midi interface? i have zero latency with apollo and MOTU midi connector.

Share This Page