Revert printer drivers to Snow Leopard

Discussion in 'Mac OS X Lion (10.7)' started by rikesh, Nov 25, 2011.

  1. rikesh macrumors newbie

    Joined:
    Dec 26, 2009
    #1
    Since upgrading to Lion, I have had trouble printing using a Canon iR3080i via USB. The printer is detected and installs successfully, but when sending a document it shows 'waiting for printer to become available'...

    On Snow Leopard I used the Generic PostScript driver and it worked fine. Now, it won't. I have also tried installing the Canon drivers from their website and using these instead, which still doesn't work.

    Please point me to a download link for the 10.6 Generic PostScript driver or upload it?

    Would be much appreciated,

    Rik
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    The generic PostScript driver is an integral part of MacOS X. What it is is the standard Apple driver used without a printer-specific PPD file. It is curious that your printer worked with MacOS X 10.6, but not MacOS X 10.7. The great change occurred with MacOS X 10.6. Your printer setup should have carried-over to MacOS X 10.7 and "just worked."

    PPD files are [for the most part] OS-agnostic:
    1. Download the Windows self-extracting archive file PPDv300Win.exe from the Canon web site.
    2. A decompressing utility like Stuffit Expander can be used to decompress this file directly to your hard drive. It will expand into a folder named PPDv300 Win that holds PPD files for just about all Canon copier/printers supported under Windows.
    3. Do a Spotlight search for a file named CNRC348U1.PPD.
    4. Move this file to /Library/Printers/PPDs/Contents/Resources.
    5. Redo your printer setup.
     
  3. rikesh, Nov 28, 2011
    Last edited by a moderator: Dec 1, 2011

    rikesh thread starter macrumors newbie

    Joined:
    Dec 26, 2009
    #3
    Thanks for your reply - I was so excited when I tried it today but alas, the same thing is happening.

    Did as you said, put that file in the correct folder. What I noticed was that all the other PPDs were in .gz compressed format? Anyway, I tried installing the printer with both Generic PostScript and Canon - still 'waiting for printer to become available'.

    Any further suggestions would be much appreciated!

    I will actually PAY the person who posts a working solution (that doesn't involve switching back from 10.7 to 10.6).
     

Share This Page