Rid of Authentification Password Prompt?

Discussion in 'macOS' started by Haz Nomis, Nov 11, 2009.

  1. Haz Nomis macrumors newbie

    Joined:
    Jan 29, 2009
    Location:
    A cold cold place.
    #1
    How do I get it so that I can add an application to my application folder without having to type in my password everytime?
     
  2. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #2
    There are at least two possible reasons for this:

    1. You are not in the admin group
    2. There is a permissions problem on the Applications folder

    If you are not an admin, you need to become one (or change permissions on the Applications folder which I don't recommend).

    If you are an admin, repair permissions as this should clear up any abnormality.

    If that doesn't help there may be an ACL that is stopping you. This could have been put in place by your sysadmin (if you have one). We can cross this bridge when we come to it.

    More details about your situation are needed. Are you the only user on the machine, etc.
     
  3. whooleytoo macrumors 604

    whooleytoo

    Joined:
    Aug 2, 2002
    Location:
    Cork, Ireland.
    #3
    Do you mean install an app package, or just dragging 'n' dropping an app into the folder? If you're running an installer, I think you're out of luck, I believe any installer installing an app will require the password. If you're copying an app in manually, calderone's advice above is spot on.
     
  4. Haz Nomis thread starter macrumors newbie

    Joined:
    Jan 29, 2009
    Location:
    A cold cold place.
    #4
    There are two admins on this computer, and I am one of them. When prompted, I am required to type in my own name and password. How do I fix it from here?
     
  5. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #5
    Open up a terminal and type in

    Code:
    ls -l / | grep Applications
    and hit Enter. Copy and paste what comes up into a post.
     
  6. Haz Nomis thread starter macrumors newbie

    Joined:
    Jan 29, 2009
    Location:
    A cold cold place.
    #6
    drwxr-xr-x+ 82 kellypeters 501 2788 11 Nov 17:53 Applications
     
  7. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #7
    Try repairing permissions. If that doesn't fix it, these two commands should do the trick. (I think)

    Code:
    sudo chmod -R +0020 /Applications
    sudo chown -R root:admin /Applications
    
    Then things things should be back in order.
     
  8. Haz Nomis thread starter macrumors newbie

    Joined:
    Jan 29, 2009
    Location:
    A cold cold place.
    #8
    "chmod: Invalid file mode: +0020"

    Are you sure I just don't have some sort of setting enabled?
     
  9. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #9
    Repair permissions before toying around in Terminal.
     
  10. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #10
    The chown command is correct to get the ownership back how it should be. The chmod command is supposed to get admin's back write permission, but it may not be correct. I'm just guessing what it would be from the man page. I really don't use chmod often enough to know.

    And what calderone said. Don't try with those scripts unless the Repair Permissions option in Disk Utility can't fix it.
     
  11. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #11
    Here is what I would run if it came down to that:

    Code:
    chown root:admin /Applications
    chmod ug=rwx /Applications
    I wouldn't run it recursively.
     

Share This Page