Ridding Computer of irrelevant information

Discussion in 'iMac' started by free2australian, Jul 18, 2012.

  1. free2australian macrumors newbie

    Joined:
    Mar 24, 2012
    #1
    I have an iMac version 10.7.4

    I found that my computer has repetitive doubling of information past and present work i have done. Searches one on the web; emails I have written and icons that remain on the computer after reading a web or downloading information.

    This I found when my spotlight search has sent me to the finder.

    Hopefully I have been able to express myself for you to understand. I am not at all technical and do not understand computer speak that well.

    I have attached some screen shots, hopefully they will assist you in assisting me.

    thank you

    sue
     

    Attached Files:

  2. Puevlo macrumors 6502a

    Joined:
    Oct 21, 2011
    #2
    Looks like maybe 3 MB worth of data. I wouldn't go about deleting things in your Mail folder either. You can relax.
     
  3. Efrem macrumors member

    Joined:
    Jul 30, 2009
    #3
    What is happening here is that, when you save an e-mail with an attachment and also save the attachment somewhere in a document folder, you end up with two copies of the attachment.

    If this bothers you, and you want to keep the original e-mail, you can select the e-mail message and then choose "Remove Attachments" from Mail's Message menu. The attachment will be deleted from the message and from your Mail Downloads folder. You will still have the copy that you saved in your Documents folder.

    However, if Puevlo is right and it's just 3MB in total, I wouldn't worry about it either.
     
  4. free2australian thread starter macrumors newbie

    Joined:
    Mar 24, 2012
    #4
    Ridding Computer of irrelevant information

    thanks for your response.

    There is much more information than I sent you as I sent you only a portion. To add this information was found with a particular certain search criteria . If I search for something else using other words, further extra nothing to do with the first double up information comes up and so it goes on and on.

    Any suggestions.

    thank you

    sue
     
  5. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #5
    If you want to keep your mail intact (as I do) but don't want to have Spotlight match the file attachments, go to System Preferences --> Spotlight, and uncheck the box for "Mail Messages". Even with this box unchecked you can still search in Mail from the Mail application. This doesn't remove any files, just alters the Spotlight search.

    For mail attachments you have opened, use Spotlight and search for "Mail Downloads". This is a folder of all the attachments you have accessed. Do a Command-A to select them all, and then a Command-Delete to delete them. If you save all your important mail there is no reason at all to keep these since you can always get the content from the message.

    As an alternative, you can use the Privacy Pane of System Preferences-->Spotlight and add "Mail Downloads". You will need the search box again to find "Mail Downloads" when you do this.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    Here is what is going on. From looking at the very bottom of your first two screen shots I can see you have the "All Mail" IMAP folder on your computer, and you do not need it.

    By having All Mail synced to your computer you end up with all new messages coming into the Inbox or whatever folder you move them to, and also having that same message duplicated in All Mail. This is why you are seeing two of everything.

    To fix it, quit the Mail app and then go to gmail.com and in settings UNCHECK "show in IMAP" for the All Mail folder. Click save settings and leave the gmail web site.

    Now start Mail app again and give it a minute to sync the changes and you should see all those dups disappear. Mail app will now use half the storage space to keep your gmail IMAP messages locally.

    [​IMG]
     
  7. free2australian thread starter macrumors newbie

    Joined:
    Mar 24, 2012
    #7
    Ridding Computer of irrelevant information

    Thank you so much for time and the information provided.

    As yet I have not changed the settings - but I will when I get some courage - my fear is doing something different and make a mistake while doing it and lack of knowledge if something goes wrong in how to rectify.

    Sue
     
  8. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #8
    If you just uncheck the box I showed you, all it will do is stop "All Mail" from showing up in the Mail app client. It will still be there at gmail.com and you won't lose anything.
     
  9. free2australian thread starter macrumors newbie

    Joined:
    Mar 24, 2012
    #9
    Ridding Computer of irrelevant information

    Well I have taken the courage to undertake the changes you have recommended to uncheck go into system preferences - spotlight and uncheck the box for "Mail messages"

    I want to confirm that I am unchecking the correct box see screen shot.

    You also mentioned that to go to gmail.com and in settings "UNCHECK' show in IMAP . I have another email account - yahoo.com. Can I do this with my yahoo mail as well? - if so, how do I do this?

    thank you

    sue
     

    Attached Files:

  10. free2australian thread starter macrumors newbie

    Joined:
    Mar 24, 2012
    #10
    Ridding Computer of irrelevant information

    Further to my most recent post I have another question in relation to information to settings " UNCHECK show in IMAP" for the Mail folder.

    In my search for settings I found reference to IMAP . However what I found differs from your screen shot. I am a bit confused what I have how how to find the information to undertake what has been advised.

    Sorry about all this - As a baby boomer but I am technically illiterate not to mentioned challenged.

    see my screen shots . My IMAP seems to be disabled

    thank you
     

    Attached Files:

  11. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #11
    If you want to remove Mail message search results from Spotlight queries, yes that is the correct box to uncheck.

    Yahoo Mail does not have this duplicate "All Mail" folder issue like GMail does, so you don't need to do anything.

    I'm confused a little. If your first post you show a screenshot where at the bottom I can just makeout a mail folder that looks like a GMail IMAP account in the Mail app. Confirm for me you do in fact have GMail configured in Mail app (not the web GMail but the OS X Mail app)? You must have GMail IMAP enabled it you would not be seeing those IMAP folders on your computer. Do you perhaps have multiple GMail accounts and you are looking at gmail.com for the wrong one?

    If you check that box you showed in your post #10 to enable IMAP, you would then see the option under the labels tab like I showed to not show All Mail in IMAP.
     
  12. free2australian thread starter macrumors newbie

    Joined:
    Mar 24, 2012
    #12
    Ridding Computer of irrelevant information

    What I was doing was going through my web browser to bring up my web gmail account and not through my mail accounts - is this incorrect?

    I am attaching screen shots of my gmail set up- Be grateful if you could let me step by step , if possible by screen shots, what I should be checking or unchecking.

    thank you

    Sue
     

    Attached Files:

  13. free2australian thread starter macrumors newbie

    Joined:
    Mar 24, 2012
    #13
    Hi Weaselboy

    With reference to the correspondence , I was wandering if you have read my last post and whether I am on the right track.

    Looking forward to hearing from you
     
  14. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #14
    Apologies. :) I missed your post.

    You Mail app settings look correct for GMail IMAP. What I still don't understand is how you are getting IMAP email if your have IMAP turned off at gmail.com in settings.

    Quit Mail app and go back to gmail.com and in settings enable IMAP and then uncheck the All Mall folder like in my screenshot in post #8. Then restart Mail app and give it a minute to sync things up and see if the All Mail folder goes away in Mail app.
     

Share This Page