Right Click - possible to have 2 finger tap AND bottom right click?

RealEvil

macrumors 6502
Original poster
Aug 5, 2007
324
12
Hi,

I have alate 2011 MBP 15". I can only set the right click to be one or the other - i.e a 2 finger tap OR bottom right click. Can I have both perform a right click?
 

dusk007

macrumors 68040
Dec 5, 2009
3,386
62
I think BTT can able two finger clicks independent of the system settings. You should be able to get both.

I don't understand why you would want it. I hated the bottom right click because it so often didn't do what I wanted when I wanted it. The two finger is just the best always works is precise and never involuntary.
 

mtip

macrumors member
Mar 11, 2010
45
0
Before Lion, Yes.

After Lion…no :(
That is not true.

In System Preferences > Trackpad > Point & Click, I have enabled Secondary Click and set it to "Click or tap with two fingers" and I can do either - tap with two fingers or click in the bottom right corner - for a right click. No extra software.

And I'm running Lion 10.7.2 on a 2010 MBP 13"
 

10k300

macrumors newbie
Oct 10, 2010
27
0
this is a true bug - the reason you can do it is because you probably upgraded from 10.6

A Fresh 10.7 install doesn't allow this. I have this on 5 Macbook Pro's 2011 models this is confirmed true. You can either have two button touch, or right corner click. If you came from 10.6 then you can retain your previous functionality.

//another guy considering to roll back everything to 10.6.8//
 

iforbes

macrumors 6502
Dec 21, 2011
327
1
I can confirm that in a new macbook pro with OS X 10.7.2, the "Click or tap with two fingers" only the tap with two fingers piece of it works. If I switch to "Click in bottom right corner" the the click works, but not in the "Click or tap with two fingers" option.
 

EmbraceTheOne

macrumors 6502a
Aug 26, 2011
656
1
That is not true.

In System Preferences > Trackpad > Point & Click, I have enabled Secondary Click and set it to "Click or tap with two fingers" and I can do either - tap with two fingers or click in the bottom right corner - for a right click. No extra software.

And I'm running Lion 10.7.2 on a 2010 MBP 13"
He's talking about doing both at the same time.

You can only have one selected in Lion.
 

Attachments

mtip

macrumors member
Mar 11, 2010
45
0
He's talking about doing both at the same time.

You can only have one selected in Lion.
Well, I have one selected ("click or tap..."), both work. Maybe it's indeed because I upgraded from Snow Leopard.

Edit: Here's how to enable it.
1. set your trackpad secondary click settings to "Click in bottom right corner"
2. open Terminal.app and enter the following command:
Code:
defaults -currentHost write -g com.apple.trackpad.enableSecondaryClick -bool YES
3. log out and back in
4. enjoy
 
Last edited:

EmbraceTheOne

macrumors 6502a
Aug 26, 2011
656
1
Well, I have one selected ("click or tap..."), both work. Maybe it's indeed because I upgraded from Snow Leopard.

Edit: Here's how to enable it.
1. set your trackpad secondary click settings to "Click in bottom right corner"
2. open Terminal.app and enter the following command:
Code:
defaults -currentHost write -g com.apple.trackpad.enableSecondaryClick -bool YES
3. log out and back in
4. enjoy
Awesome, Works!
 

bdodds1985

macrumors 6502a
Jul 18, 2011
867
0
Tartarus
I don't understand why you would want it.
because not everyone hates the right click option as much as you, or maybe to some its faster or more purposeful.

i used to use the right click but lately i have been using the two finger. i think its faster to have a right click button at the bottom because sometimes i have to tap my two fingers a couple times. no big deal though. only reason i use it at all is because i bought an external trackpad and when that thing goes portable it has to be on a hard surface for you to "click" anything.
 

bdodds1985

macrumors 6502a
Jul 18, 2011
867
0
Tartarus
Well, I have one selected ("click or tap..."), both work. Maybe it's indeed because I upgraded from Snow Leopard.

Edit: Here's how to enable it.
1. set your trackpad secondary click settings to "Click in bottom right corner"
2. open Terminal.app and enter the following command:
Code:
defaults -currentHost write -g com.apple.trackpad.enableSecondaryClick -bool YES
3. log out and back in
4. enjoy
so to disable it at the end just put NO instead of YES?
 

Wattser93

macrumors regular
Sep 6, 2010
176
0
Mine retained it from Snow Leopard. Thanks for the terminal command. I've been trying to find a way to make it work on our family MBP that had to have a fresh install.
 

aeronauticsrock

macrumors member
Jan 30, 2010
83
0
The terminal command worked for my internal MBP trackpad, but not my Magic Trackpad, which just works with lower right click.

Anyone know what I could do to get BOTH working on the magic trackpad as well?

Thanks!
 

tryiian

macrumors newbie
Jan 31, 2008
17
0
I just wanted to chime in and say thank you so much for the terminal command for those of us who made the "mistake" of installing .7 or .8 fresh.

Also if anyone can come up with one for the magic trackpad too, I would appreciate this too.
 

mobilegreg

macrumors newbie
Nov 21, 2013
2
0
Thank you so much

Well, I have one selected ("click or tap..."), both work. Maybe it's indeed because I upgraded from Snow Leopard.

Edit: Here's how to enable it.
1. set your trackpad secondary click settings to "Click in bottom right corner"
2. open Terminal.app and enter the following command:
Code:
defaults -currentHost write -g com.apple.trackpad.enableSecondaryClick -bool YES
3. log out and back in
4. enjoy
Worked great! SSD MBP OS X 10.9.1
 

bdspilot

macrumors newbie
Nov 14, 2011
27
4
Well, I have one selected ("click or tap..."), both work. Maybe it's indeed because I upgraded from Snow Leopard.

Edit: Here's how to enable it.
1. set your trackpad secondary click settings to "Click in bottom right corner"
2. open Terminal.app and enter the following command:
Code:
defaults -currentHost write -g com.apple.trackpad.enableSecondaryClick -bool YES
3. log out and back in
4. enjoy
I can't get this to work in Yosemite 10.10.3. Is anyone having luck?
 

morinetti

macrumors newbie
Jun 23, 2010
18
0
Vilnius, Lithuania
Here's how to enable it.
1. set your trackpad secondary click settings to "Click in bottom right corner"
2. open Terminal.app and enter the following command:
Code:
defaults -currentHost write -g com.apple.trackpad.enableSecondaryClick -bool YES
3. log out and back in
4. enjoy
This does not work on El Capitan 10.11.4.
Can't find anywhere on google how to fix this bug. :(
Please reply if anyone find a fix for this. Thank you in advance.
 

julia freeman

macrumors newbie
Oct 28, 2016
1
0
this worked for me (fresh el capitan install)

defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad TrackpadCornerSecondaryClick -int 2
defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad TrackpadRightClick -bool true
defaults -currentHost write NSGlobalDomain com.apple.trackpad.trackpadCornerClickBehavior -int 1
defaults -currentHost write NSGlobalDomain com.apple.trackpad.enableSecondaryClick -bool true
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.