Right click will not work at all

Discussion in 'OS X Yosemite (10.10)' started by blasto2236, Aug 30, 2014.

  1. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #1
    I've checked my System Preferences for the mouse and the right click option is definitely turned on, but it won't recognize the setting at all. Have to ctrl+click to bring up the menu every time. Anyone else on the Yosemite beta had this issue?
     
  2. tmoerel macrumors 6502

    Joined:
    Jan 24, 2008
    #2
    Have you tried another mouse? Perhaps the button is broken...
     
  3. notrack macrumors 6502

    Joined:
    Feb 19, 2012
    #3
    Now that you mention it... I noticed that right click didn't work when I wanted to adjust the toolbar via the context menu. I tried it several times. I don't exactly recall which app it was. The menu bar item was available though. Safari I believe.
    Right click also didn't work at a nother place but I really can't remember. I just thought they killed that feature since it worked otherwise.
     
  4. blasto2236 thread starter macrumors 6502a

    Joined:
    Nov 4, 2012
    #4
    It's the Magic Mouse, so they don't have separate buttons, it just detects which side of the mouse you are clicking on. I would guess that if it was a mechanical issue with the button then I wouldn't be able to click on anything at all.

    Something similar happened when I first installed Yosemite, but I went in to settings and it had just unchecked the box to enable Secondary Click. Now when I go to settings the box is checked but it still doesn't work.
     
  5. NewbieCanada macrumors 68030

    Joined:
    Oct 9, 2007
    #5
    It's working for me - trackpapd though, not mouse.

    Maybe try removing the mouse and re-pairing it? No reason it should work, but it won't hurt to try it.
     

Share This Page