Ringer Volume Not Working

robjulo

macrumors 65816
Original poster
Jul 16, 2010
1,283
1,980
Having an issue that started today. I cannot turn my ringer (or other sounds effects or music for that matter) up. When I hit the volume up button, the "Ringer Icon" shows up but refuses to increase. The sound on/off button is switched on (i.e. no orange is showing) and seems to be working (as when I turn it off, the phone vibrates). Music will not sound (it is playing) without the headphones in. Sound effects do not work.

If headphones are in, music plays and sounds normal (through the headphones)and I can control the headphone volume as normal. Sound effects also work through the headphones.

Also, I should note, when I hold the home button, Siri sounds normal. Also, when I go to General Settings and move the volume slider, the ringtone sounds as normal (and in fact the slider can be controlled via the vol up and down buttons; also when I make a call and use the speaker phone, it works fine, so the external speaker is definitely working.

Any ideas? I've already rebooted and already restored settings. I have not done a full factory reinstall and hope to avoid it.
 
Last edited:

JAT

macrumors 604
Dec 31, 2001
6,511
122
Mpls, MN
Check the mute switch. Maybe at an Apple Store. Cause it really sounds like that's the problem.
 

Hosei

macrumors member
Mar 1, 2012
86
0
NY, NY
I agree with JAT, maybe you should consult with the apple store and see what they offer to you
 

robjulo

macrumors 65816
Original poster
Jul 16, 2010
1,283
1,980
Took it in and they swapped the phone out. All is well now.

Their assumption was something was going on with the headphone jack.
 

mrquin27

macrumors newbie
Mar 5, 2012
13
0
You have to put your mouth on the headphone jack and suck.. You can't blow on it, you have to suck for it to work. This isn't even a joke google it. Mine does it from time to time. I looked it up and I tried blowing on the headphone jack like the post said wouldn't work.. And still no fix. I sucked on the headphone jack (no tongue) and it has fixed it for me more than once.

Sounds really retarded but I assure you this does work. Google if you don't believe it.
 

700-Grizz

macrumors 6502
Sep 9, 2010
441
63
ALASKA
I just replaced my 4S because my up vol button stopped working as well--felt stuck in, it had no indent at all. They gave me a new one whiten 5 minutes
 

carosche

macrumors newbie
Jul 29, 2012
1
0
Texas
You have to put your mouth on the headphone jack and suck.. You can't blow on it, you have to suck for it to work. This isn't even a joke google it. Mine does it from time to time. I looked it up and I tried blowing on the headphone jack like the post said wouldn't work.. And still no fix. I sucked on the headphone jack (no tongue) and it has fixed it for me more than once.

Sounds really retarded but I assure you this does work. Google if you don't believe it.
OMG! This worked! Thank you!
 

Hls112

macrumors newbie
Dec 18, 2012
1
0
Hi Robjulo - I'm having exactly the same problem with my iPhone 4S as of today. I've worked through everyone's suggestions on this thread but none of them seem to work. Did you manage to sort the problem you were having? Anyone else any other ideas (aside from going into the Apple Store)?
Not sure if it's relevant, but every so often for a couple of seconds the sound will return.
 

Lunchbox700

macrumors regular
Jul 18, 2008
185
0
MN
I also had this problem, it's not always the earphone jack sometimes it's the dock connector the phone thinks its plugged in to a speaker dock and so disables volume controls. Take it in to be replaced. The only thing is hope you get someone that realizes almost all phones water detector has been tripped. He looked at mine and was like "yea the sensor tripped,but the phone looks fine" and swapped them for me.
 

bonvits13

macrumors newbie
Feb 20, 2013
5
0
Thanks LunchBox700

Thanks LunchBox700.
It really work. I change the dock then the volume for the ringer is now fully functioning.:)


I also had this problem, it's not always the earphone jack sometimes it's the dock connector the phone thinks its plugged in to a speaker dock and so disables volume controls. Take it in to be replaced. The only thing is hope you get someone that realizes almost all phones water detector has been tripped. He looked at mine and was like "yea the sensor tripped,but the phone looks fine" and swapped them for me.
 

skier8689

macrumors newbie
Mar 17, 2009
19
12
New York
You have to put your mouth on the headphone jack and suck.. You can't blow on it, you have to suck for it to work. This isn't even a joke google it. Mine does it from time to time. I looked it up and I tried blowing on the headphone jack like the post said wouldn't work.. And still no fix. I sucked on the headphone jack (no tongue) and it has fixed it for me more than once.

Sounds really retarded but I assure you this does work. Google if you don't believe it.
This worked for me. Thank you!
 

erichess22

macrumors regular
Feb 25, 2013
118
0
Same thing happened to me before, it is a bug where your iphone things that headphones are still plugged in. The only way to fix it for me was to restart phone or to plug in headphones and take them out.
 

Bako-MacAddict

macrumors 68000
Jun 7, 2012
1,803
855
California
You have to put your mouth on the headphone jack and suck.. You can't blow on it, you have to suck for it to work. This isn't even a joke google it. Mine does it from time to time. I looked it up and I tried blowing on the headphone jack like the post said wouldn't work.. And still no fix. I sucked on the headphone jack (no tongue) and it has fixed it for me more than once.

Sounds really retarded but I assure you this does work. Google if you don't believe it.
"You have to put your mouth on the headphone jack and suck.. You can't blow on it, you have to suck for it to work."


Yep, that's what she said ...:D
 

Dmurph

macrumors newbie
May 22, 2013
1
0
I tried sucking in on the headphone jack but that didn't work at first. Then I tried blowing on the bottom speakers and into the iPhone dock and it turns out they were somewhat dirty and may have accumulated some misty precipitation. Everything works fine now.
 

edddreeb

macrumors newbie
Jul 20, 2013
1
0
Dmurph, Thank you a thousand times. I tried EVERYTHING on EVERY forum, and finally found yours. I also blew on the dock and speaker openings. I'm not sure which one worked, but the sound is working again! :)
 

CR33P3RF1ST

macrumors newbie
Apr 4, 2014
1
0
FINALLY! it works! tried sucking, NOPE. Then all the other things like assistive touch and all that, NOPE. Then i saw the blowing one. worked!