Ringtones not working...

Discussion in 'iPhone Tips, Help and Troubleshooting' started by axeldtf, Oct 15, 2011.

  1. axeldtf macrumors 6502

    Mar 3, 2007
    Since upgrading to ios5.. some of my custom ringtones arent working. They arent showing up in the iphone and itunes there is an exclamations point next to the ringtone. Is anyone else having that same problem?
  2. synchro505 macrumors newbie

    Jan 16, 2008
    Experiencing a similar issue here.

    Ringtones will not seem to transfer to my iPhone 4 (upgraded to iOS5) via iTunes 10.5.

    Selecting the iPhone under Devices in iTunes shows no Ringtone category in the top middle section. There is no Ringtones category to check and uncheck.

    If I drag a .m4r type ringtone (32 seconds long) onto my iPhone icon in iTunes, it transfers but shows the file in gray. Syncing at that point does not make a difference.

    The custom ringtones I drag to my iPhone do not appear in the Sounds preferences, only the factory ringtones appear.

    I've tried creating new .m4r ringtone files, restoring the iPhone twice (second time as new iPhone), un-installing iTunes 10.5 and all related .plist files, but no luck.

    I am thinking of doing a complete reset of the phone and trying it on another Mac. What do you think?
  3. silo 1 macrumors newbie

    Oct 15, 2011
    I'm getting the same issue.
    iTunes 10.5, iPhone 4s iOS5

    Tried recreating .m4r flies and re-adding to iTunes ringtone library.
    now when I sync the iPhone it goes through sync process and gets stuck on the final step: "8 of 8 waiting for items to copy"

    anyone have any ideas why the sync isn't completing? is it to do with ringtones or something else?

    am complete newbie to forums so apologies if I'm missing something that's already been added...
  4. axeldtf thread starter macrumors 6502

    Mar 3, 2007
    Yea that stinks.. hopefully apple will have a fix soon
  5. CeeDotA macrumors newbie

    Oct 16, 2011
    The West Coast
    Mine didn't carry over too. I created them the quick way -- create an AAC clip of a song, then change the suffix to m4r. I went back and re-created them in GarageBand, and they work just fine now.

Share This Page