Ripit files have turned into folders :P

Discussion in 'Mac Apps and Mac App Store' started by jonutarr, Feb 16, 2010.

  1. jonutarr macrumors regular

    jonutarr

    Joined:
    Sep 1, 2006
    Location:
    OZ
    #1
    Hi guys

    I tried changing my default .dvdmedia files player from DVD Player to VLC and they ended up turning into folders:

    [​IMG]

    Can anyone help me change them back?
     
  2. rk1991 macrumors regular

    Joined:
    Dec 10, 2009
    #2
    ripit does not convert the files to a .avi or any other video format. It simply extracts the entire dvd onto the hard drive. It should still play in vlc though. Also if you do not want ripit to make a .dvdmedia folder but just a video_ts folder then you can change it under the preferences.
     
  3. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #3
    Well, actually, .dvdmedia "files" are always folders. They just look like "files" in Finder because displays them as packages. I'm not sure what you've done, since when I open a .dvdmedia package in VLC, it remains a package, not a folder.

    I assume that if you right-click/Get Info on one, you don't get the Open With: option?
     
  4. jonutarr thread starter macrumors regular

    jonutarr

    Joined:
    Sep 1, 2006
    Location:
    OZ
    #4
    No I can't open it with any application, there is no option for that in "get info" which is were I tried to change it

    Could be a bug inside a Snow leopard, I don't care that actually, .dvdmedia "files" are always folders.

    I just want them to play on VLC or DVD player again, right now they are useless to me
     
  5. mrfridays macrumors newbie

    mrfridays

    Joined:
    Jan 2, 2010
    #5
    If the file you are trying to change is not on your Macintosh HD or is located on an external drive and that drive doesn't have appropriate rights/permissions, you will not get the "Open With" option on the Get Info window.

    Short version/ Quick fix: locate a .dvdmedia file/package on your Mac HD and bring up the "Get Info" window for it. You should see the Open With option now. Make your file type association change there, and the ones on your external drive/storage device should change as well I believe.
     
  6. jonutarr thread starter macrumors regular

    jonutarr

    Joined:
    Sep 1, 2006
    Location:
    OZ
    #6
    That's the was the point of me making this thread & as I've said before, there is not an "open with" option

    [​IMG]
     
  7. deputy_doofy macrumors 65816

    deputy_doofy

    Joined:
    Sep 11, 2002
    #7
    You should be able to open the VIDEO_TS folder itself with VLC, but not necessarily Apple's DVD player.
     
  8. mrfridays macrumors newbie

    mrfridays

    Joined:
    Jan 2, 2010
    #8

    Instead of being a combative douche why don't you read my entire post and then realize the answer you are looking for is inside it?



    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  9. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
    #9
    simply get rod of the .dvdmedia extension and you will just see folders
     
  10. jonutarr thread starter macrumors regular

    jonutarr

    Joined:
    Sep 1, 2006
    Location:
    OZ
    #10

    lol how ironic, If you read my posts you would see the .dvdmedia extension has always been there and is still showing as an unplayable folder

    Just go away please, I'm looking for a solution not insults
     
  11. rk1991 macrumors regular

    Joined:
    Dec 10, 2009
    #11
    just to clear things up did u try to play the video_ts file on vlc. Does that have an open with. Also try opening the file through vlc from the file menu. Another thing you could do is extract the video_ts file from the .dvdmedia file because that is not really needed. I do not rip my dvd files to .dvdmedia anymore.
    Check the screen shot of my ripit preferences. Hope this helps
     

    Attached Files:

  12. mrfridays macrumors newbie

    mrfridays

    Joined:
    Jan 2, 2010
    #12

    I never argued that the .dvdmedia extension was missing. You aren't getting the "Open With" option because the file permission doesn't allow for it. Show us a screen shot of the 'Get Info' window for that folder please. And again, is the folder on your Mac HD or an external drive?
     
  13. jonutarr thread starter macrumors regular

    jonutarr

    Joined:
    Sep 1, 2006
    Location:
    OZ
    #13
    well I updated vlc and that ^ worked! Thanks! A bit of a work around but I am happy the can play the movies again, would be great to get the "open with" option back again though

    I had permission before but not now :confused:

    [​IMG]

    Everything is on Mac HD
     
  14. ggmt827 macrumors newbie

    Joined:
    Aug 28, 2010
    #14
    I had the same problem. Here's how I fixed it:

    1. Open TextEdit (or some text editor), create a small text file and save it.
    2. Right-click on the text file, and choose "Get Info".
    3. Under Name & Extension, change the extension to ".dvdmedia". Hit Enter to save this change.
    4. Under Open With, the associated program should be showing VLC. Select DVD Player instead, and save that change.

    Now all the .dvdmedia folders should be reassociated with DVD Player.
     
  15. kernkraft macrumors 68020

    kernkraft

    Joined:
    Jun 25, 2009
    #15
    I can see that the issue got fixed. I just wanted to say that many things that appear as single files on the Mac are actually folders. Also, there are much more to the file structure that it first appears. By default, a lot of files are not visible, so users don't get confused or accidentally delete them.
     

Share This Page