Ripping Movies w/ Subtitles

Discussion in 'Apple TV and Home Theater' started by UhFive, Jul 15, 2014.

  1. UhFive macrumors regular


    Sep 17, 2013
    I am pretty new to ripping movies and have been using MakeMVK to rip the movies to my computer and then Handbrake to convert them to an iTunes playable format (.MP4).
    I just ripped about 90 Blu-rays and it wasn't until I was skipping through "Avatar", to check the quality, that I noticed the subtitles weren't working. I re-ripped the movie and this time made sure subtitles were there...unfortuanately the subtitles are always on now.
    I see on the Apple Tv there is a section for subtitles to be turned on and off, what I want is to be able to rip a movie with the function of turning on and off and also to only have subtitles show up for non English speaking parts like Avatar.
  2. jdblas69 macrumors regular

    Aug 15, 2012
    When I first started ripping my movie collection it was Avatar as well where I realized I was doing something wrong with the subtitles.

    This what I did to make it work and appears to work with other movies is rip the movie with Makemkv like you normally would. When you add the file to handbrake for encoding, click on the subtitles menu and click where it says none and click foreign audio search and "forced in" and "burned in" should be checked.

    This worked for Avatar and for the most part has worked on other movies I have ripped.
  3. MarkCollette macrumors 68000


    Mar 6, 2003
    Toronto, Canada
    Handbrake itself will rip and include (multiple) subtitles that can be turned off, and directly save to Apple compatible formats.
  4. westrock2000 macrumors 6502a

    Oct 18, 2013
    The "Foreign Audio Search" and "Forced Only" are similar operations. The difference is that Foreign Audio Search will scan the disc and see what language is "forced" automatically by the movie and then it will rip that. "Forced Only" allows you to select a certain language from the drop down box and then have Handbrake only burn in what is forced within that particular language.

    Generally, you want to select Foreign Audio Search and Burn In. Because sometimes movies can break up the subtitles weird and you may not select the right language. For instance a movie having aliens talk and it being a separate "English" track from the real English subtitle track.

    Unfortionantly Foreign Audio Search adds about 30 minutes to the length of the processing time because it has to scan the entire movie first to see what was forced. Also be sure to select your native language in the Options for Handbrake so that the DVD will force the right language.
  5. rosiel122 macrumors newbie

    Feb 24, 2014
    A method that I have used and works for me is to use VLC and manually go through subtitle options and find the right one. It is more tedious, but generally works well.
  6. MacUser09 macrumors regular

    Sep 26, 2009
    It was along time ago that I ripped Avatar, but I remember it was a real pain trying to get just the Na'vi spoken part subtitles. I can't remember the exact process, but it involved using BDSup2sub + MKVtoolnix or MKVtools.

    Perhaps things are easier now. Sorry I can't be more helpful.
  7. BulkHedd macrumors 6502


    Nov 13, 2006
    Bringing up an old thread here but I'm having subtitle problems.
    Normally I just find the SRT file and add that to Handbrake when converting a MKV (ripped from BR) to M4V.

    I wanted to rip my Lord of the Rings Extended Edition BRs but each movie is divided onto 2 discs. I can find SRT files broken in two.

    I added the English PGS subtitles in Handbrake and did not choose "burn-in" but playing the file in VLC the subtitles are always there and can't be turned off. There are no subtitle tracks shown so it must be burned in.

    Luckily the Elvish parts are printed on the film so I don't have to worry about that. I just like to have the English subtitles there so I can turn them on if I want to.
  8. priitv8 macrumors 68040

    Jan 13, 2011
    PGS subs are bitmaps (in contrast to SRT subs, which are ASCII text). AFAIK HandBrake does not know how to mux bitmapped subs into a MP4 file, so if you select such a track, it will burn them into the picture. Also, if I'm not mistaken, MP4 file by definition (at least that's what Apple QuickTime can play back) allow only text sub tracks, not bitmapped ones.
    Luckily, Subler can OCR bitmapped subs on the fly, but the result requires heavy spell-checking, at least in my attempts.

Share This Page