Rise of Nations Nuke Glitch

Discussion in 'Mac and PC Games' started by Neiliongufler, Feb 16, 2009.

  1. Neiliongufler macrumors newbie

    Joined:
    Feb 16, 2009
    #1
    When playing rise of nations on my 2.4 Ghz 4gb ram Intel Mac, I decided to detonate a nuclear device on the hapless Lakota.

    However, as soon as the bomb went off, all of the terrain went black and so did the interface. I tried playing a different kind of game, and I downloaded the 1.0.1 patch, but still nukes are failing.

    Does anyone else have this problem? If so, have you fixed it?

    Thanks in advance.
     
  2. jakeguy99 macrumors regular

    jakeguy99

    Joined:
    Jan 21, 2007
    #2
    Never had the problem or heard of it, try google. If not id reinstall, or make sure your hardware is all good inside if ya know what i mean.
     
  3. Neiliongufler thread starter macrumors newbie

    Joined:
    Feb 16, 2009
  4. chicagdan macrumors 6502a

    Joined:
    Jan 3, 2002
    Location:
    Chicago, IL
    #4
    This is the best description of Karma that I've ever seen.
     
  5. Neiliongufler thread starter macrumors newbie

    Joined:
    Feb 16, 2009
    #5
    I tried reinstalling, but it didn't work. I'm beginning to become very frustrated.:mad:
     
  6. dfj01 macrumors newbie

    Joined:
    Feb 19, 2009
    #6
    Same Problem.

    I am having the same problem. It really sucks and it's hard to get out of the game without a hard reset.
     
  7. BertyBoy macrumors 6502

    Joined:
    Feb 1, 2009
    #7
    Civ IV used to do the same to me, try reducing the colour depth before starting. Sounds like the colour map is shot during the graphics for the nuke.
     
  8. chriszy macrumors newbie

    Joined:
    Feb 28, 2009
    #8
    Hello,

    I have exactly the same problem.
    All the screen become almost black.
    One time have been able to recover the original by a combinaison of click on the colored life panels of the soldiers ....

    Could it be a software problem of the video card ?

    Best regards,
    Chriszy
     
  9. yoshinatsu macrumors member

    Joined:
    Oct 17, 2007
    Location:
    Downtown Jigoku
    #9
    Happens to me too... And I'm reaaaaaaaaaally pissed of at MacSoft...
     

Share This Page