rMBP 13" no computer sleep in energy saver

Discussion in 'OS X Mavericks (10.9)' started by tigerintank, Nov 21, 2013.

  1. tigerintank macrumors regular

    Joined:
    Jun 16, 2013
    #1
    Posted this on the MBP forum but a few reads and no replies - thought it might be better here.

    Have a new rMBP 13" and i noticed that although i'd closed the lid yesterday thinking i was putting it to sleep, it was listed on the sidebar of my other mac just now, as tho it wasn't sleeping.

    Trying to investigate and can't see the computer sleep slider in system prefs on battery or power adaptor. This is my first use of mavericks previously snow leopard is as far as I've gone - so maybe it's somewhere else?
     
  2. tigerintank thread starter macrumors regular

    Joined:
    Jun 16, 2013
    #2
    no replies to either of my posts, not sure if i should interpret something there...like maybe it was a dumb question.

    Anyway a follow up question, that fits here rather than the MBP forum.

    Is there any value in reloading mavericks to try to fix the problem?

    if the answers obvious - pls feel free to tell me anyway - as its not obvious to me :D
     
  3. xspicer89x macrumors member

    Joined:
    Oct 28, 2013
    #3
    did u have it plugged in? in the energy preferences under adapter power there is the option to wake for network access. Maybe that was it? were you running any tasks at the time (ex downloading with utorrent or something?)
     

    Attached Files:

  4. tigerintank thread starter macrumors regular

    Joined:
    Jun 16, 2013
    #4
    Thanks for the reply xspicer89x

    I did have wake for access checked I think. Don't think i was running any apps that would keep it awake. But in any case i think that was just a lead for me to the actual problem.

    Where you have 2 sliders for display and computer sleep in the attached picture, i have only the one for display sleep. That can't be right surely?

    When i put the machine to sleep - i think its actually only sleeping the display. Which would explain why it's still in the sidebar of other machines.
     

    Attached Files:

  5. xspicer89x macrumors member

    Joined:
    Oct 28, 2013
    #5
    ya that is quite weird lol i have no idea why there is only the one slider for you. Try putting your mac to sleep from the apple icon in the menu bar. Leave it open. Now look at the light on the front of your macbook (in the bottom right hand corner by the trackpad). It should be blue. Wait a couple of seconds (may take up to a minute or two) to see if the blue light starts to dim and then re-brighten, and then dim/re-brighten. If it does, your computer is actually asleep. It it stays the solid blue and does not dim/re-brighten then its not sleeping.
     
  6. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #6
    IIRC, I thought I read that Macs with the new Intel Haswell processors don't have the option in System Preferences any more because these processors have a new low-power idle mode built into them.
     
  7. xspicer89x macrumors member

    Joined:
    Oct 28, 2013
    #7
  8. tigerintank thread starter macrumors regular

    Joined:
    Jun 16, 2013
    #8
    Thanks for the input both.

    I think i need to read the review of mavericks on Ars - its been recommended.

    Whilst i'm doing that over the next week or so - i'll stop worrying about the sleep status and shut it down overnight. it boots pd quickly anyway.
     

Share This Page