rMBP 2015 Force Click not working in some scenarios

Discussion in 'MacBook Pro' started by Medi111, Apr 1, 2015.

  1. Medi111 macrumors newbie

    Joined:
    Apr 1, 2015
    #1
    Hi everyone,

    2 weeks ago I bought the new 2015 rMBP and I've been having problems with the Force Click features, as far as I can see the actual trackpad is fine as the features work fine on quicktime (variable speeds with the variable pressure) and I can feel the second click, however, in applications like Safari and Finder it doesn't work, I can't look up any words and Quick Look isn't working either.

    Can anyone help?
     
  2. Jason D. macrumors newbie

    Joined:
    Oct 15, 2011
    Location:
    Los Angeles, CA
    #2
    Same exact problem here. Just bought my new rMBP. For the first few hours it worked. Now it's not looking up words. I can feel the click but nothing happens on screen.

    Anyone else have this problem?
     
  3. Jason D. macrumors newbie

    Joined:
    Oct 15, 2011
    Location:
    Los Angeles, CA
    #3
    Figured it out!

    Go to SYSTEM PREFERENCES

    Then TRACKPAD

    Under LOOK UP & DATA DETECTORS it should say "Force click with one finger", mine had been changed to "tap with three fingers" for some reason. Don't know how that happened, but there ya go!
     
  4. Medi111 thread starter macrumors newbie

    Joined:
    Apr 1, 2015
    #4
    Thanks so much! Works perfectly now!
    yeah, I have no idea how it changed either :confused:
     
  5. Twitie macrumors newbie

    Joined:
    Apr 17, 2015
    #5
    I have the same issue but it's still not working after changing to "Force click with one finger".

    Here are my experiments and findings so far:

    1) It only worked on the first day

    2) I have "Force click with one finger" set for "Look up & data detectors". It still doesn't work. I switched to "Tap with three fingers" and the look up works fine.

    3) I tried Force Click on other functions (eg: calendar, quicktime, dock, etc) all are working fine. This indicates that hardware is good.

    4) I upgraded OS X to 10.10.3 and it does not work still.

    I am totally stuck now and appreciate for any suggestion on what might have gone wrong. Thanks!
     
  6. Gruujay macrumors newbie

    Gruujay

    Joined:
    Jul 29, 2015
    #6
    I cannot use the force click with PAGES , but it works perfectly with Safari , How do I turn it on , Thanks
     
  7. Gruujay macrumors newbie

    Gruujay

    Joined:
    Jul 29, 2015
    #7
    It works when I change to Tap with three finger under system preference but when I change back to Force Click, it doesn't work
     
  8. rellerby macrumors newbie

    rellerby

    Joined:
    Aug 22, 2015
    #8
    I have this exact same problem. Force Click works everywhere except Pages. Three finger taps works on Pages though. Can anyone help?
     
  9. omeileo macrumors newbie

    omeileo

    Joined:
    Sep 19, 2016
    #9
    Go to System Preference, Trackpad, Point & Click, and turn Force Click off then on. Also, ensure that the Force Touch to do different stuff checkbox is checked.
     

Share This Page