[rMBP] Black screen with bootcamp

Discussion in 'MacBook Pro' started by Eduardboon, Jul 17, 2012.

  1. Eduardboon macrumors regular

    Joined:
    Jul 17, 2012
    #1
    Hello all,

    So I finally got my rMBP after a 5 week wait and it is an amazing machine. When I tried to install Windows, however, I ran into a big problem.

    I can't even get to the windows installer! I tried Windows 7 and Windows 8, both via Boot camp assistent to my USB Flash Drive. Neither of them can open the setup. Instead I just get a Black screen. That's it. No flashing underscores, just a black screen. And nothing happens.

    When I boot the EFI loader from the windows 8 disk I can actually launch windows setup, but it puts ALL my devices (SSD, and 2 connected USB devices) on a single disk called DISK0. Windows won't install on any of the partitions and just comes up with an: "Partition table isn't GPT" error. Weird, because the partition table is in fact GPT.

    Anyone ran into similar issues with the rMBP? Should I get a replacement? I really need windows to work for some programs. And I do really need to bootcamp in to windows.

    Thanks for the thoughts.
     
  2. djmoody macrumors regular

    Joined:
    May 13, 2012
  3. Eduardboon thread starter macrumors regular

    Joined:
    Jul 17, 2012
    #3

    Did you also use a USB Flash drive?

    I even tried a USB cd drive, but al the same; doesn't work --> black screen.

    Guess I'm gonna call Apple tomorrow.

    Actually called them this afternoon about the problem; they said I shouldn't use an illegal version of windows (I am using a legit version of 7, for the record). They couldn't be budged to believe otherwise. I'll try again tomorrow and see if I can keep this machine till the new one arrives.
     
  4. djmoody macrumors regular

    Joined:
    May 13, 2012
    #4
    I used a flash drive.
     

Share This Page