rMBP connected with HDMI random weird color saturation

Discussion in 'MacBook Pro' started by Omnirai, Nov 28, 2013.

  1. Omnirai macrumors member

    Joined:
    Jan 8, 2012
    Location:
    Antwerp
    #1
    Hey everyone,

    I've been searching on google for a while for a 'fix' for my problem, but no succes.
    My problem is this: I connect my rMBP (haswell, 13") through HDMI to my Philips TV. On random occasions, the saturation of the screen changes to green, or sometimes to pink..

    Does anyone have an idea how to fix this?


    I took a photo of my problem:

    [​IMG]


    Thanks ahead
     
  2. c1phr macrumors 6502

    Joined:
    Jan 8, 2011
    #2
    Have you been able to successfully use the same HDMI cable/port with another device, or have you tried connected the Mac with a different cable? Just to rule out everything else in the chain before focusing on the Mac.
     
  3. Omnirai thread starter macrumors member

    Joined:
    Jan 8, 2012
    Location:
    Antwerp
    #3
    I am going to try a new HDMI cable tomorrow.

    on a side note:
    My friend's older MBP (2011 version i believe) had the same random occurring color saturation problem, but after a long search he found a file that fixed it for him.

    We've been searching for that file, but no success. So I think its not the HDMI cable, but you never know. A cable cost 10€ max so worth a try.


    Ill give an update tomorrow when I bought the new cable.
     
  4. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  5. Omnirai thread starter macrumors member

    Joined:
    Jan 8, 2012
    Location:
    Antwerp
    #5
    https://discussions.apple.com/thread/3039908?start=30&tstart=0
    --> reply of chririt on that page

    I think I found that file that was the solution for my friend's mbp. I downloaded and moved it to the specified directory.

    I watched a full movie on my rMBP connected to my tv and the issue seems to be resolved.. Anyone has an idea why that was the solution?
     
  6. velihukka macrumors newbie

    Joined:
    Oct 3, 2013
    Location:
    Helsinki, Finland
    #6
    I had that problem with my MBP too, just fiddling around with the resolution should help.
     
  7. dimme macrumors 65816

    Joined:
    Feb 14, 2007
    Location:
    SF, CA
    #7
    I have a similar problem with my late rMBP hooked up to my dell U2410 via hdmi, but it only shows up in chrome. So my my solution in not to use chrome.
     

Share This Page