RMBP doesn't display full desktop when connected to hd tv

Discussion in 'MacBook Pro' started by miles400, Aug 2, 2012.

  1. miles400 macrumors member

    miles400

    Joined:
    Jul 4, 2012
    #1
    Hi when I connect my RMBP to any HD tv and set the resolution to the recommended setting (1920x1200) on either extended display or clamshell mode the tv doesnt show the whole desktop when it should because the tv was set at it's recommended resolution, this occours using the HDMI port or the thunderbolt port to vga connector also this isn't an OS related issue as this happens under windows or OS X. Is there any way to resolve this or is it a fault?
     
  2. katmeef macrumors 6502

    Joined:
    Jul 20, 2010
    #2
    Maybe use a resolution the same or lower than your HDTV? There are no 1200p TVs :p
     
  3. Rocky244 macrumors regular

    Joined:
    Jun 14, 2012
    #3
    When you plug in the rMBP to the TV, find the system preferences and make sure that the display setting is on 'Best for External Display'. (I'm assuming you are using mirror mode, but this should work for either or)

    Once you have made sure you are on 'Best for External Display', find the remote for your television. Make sure it is the actual TV remote, don't get confused by your cable remote, you need the actual TV remote that came with the set.

    On the remote find a button (usually near the bottom, for mine it's actually right on top) that will allow you to change the aspect ratio of the TV. I forget what it is usually called, something with a P.. I think. Maybe PIC, or something along those lines, you'll know it when you hit it because your TV aspect ratio will start changing. Mine's called Pixel I think... anyway depending on the type of TV you have you should be able to look up where the button is online if you really can't find it.

    Also depending on your TV, you will have a few options for aspect ratio. The one you are looking for is the most zoomed OUT aspect ratio. On Samsungs, it's usually Just Scan, or perhaps Wide 16:9... On Toshiba it's called Native (NOT Full). You'll notice some of these ratios are very similar to others. Make sure you use the one that allows you to see the entire (native) resolution of the screen.
     
  4. miles400 thread starter macrumors member

    miles400

    Joined:
    Jul 4, 2012
    #4
    No matter what resolution I use the display cant display the full picture

    ----------

    Thanks for your advice I will try and find that button on the remote
     

Share This Page