rMBP early 2013 2.7ghz lag?

Discussion in 'MacBook Pro' started by Elektrikz, Feb 27, 2013.

  1. Elektrikz macrumors member

    Joined:
    Feb 27, 2013
    #1
    Hey guys,

    I am new here and hoping for a bit of advice.

    I am totally new to Mac and decided to buy the retina MacBook Pro 15 inch 2.7ghz with 16gb of Ram on Friday and I love it!

    However I do have a small problem!

    I have noticed the laptop lags when I am copying largish files, here is an example... I play football manage and downloaded all the face packs which required me to copy say 3000 images a a time totalling close to 150mb... What I have noticed is the loading bar will stop and move up every minute or so and I see a multi colour loading circle allot? The loading bar does not move as normal if you get me?

    I was thinking that for a £2000 machine surely it should be able to handle copying large amounts of images to folders like a breeze?

    I also have a 512gb SSD in case that is of any help?

    Oh and one more thing whilst I'm here, I installed Rollercoaster tycoon 3 which is a good few years old and the game lags badly when the graphics are on high quality? Also I can no longer play the game as when I load it up the main menu is half missing etc!

    Thanks so much for any help and sorry to bore you lol!
     
  2. Elektrikz thread starter macrumors member

    Joined:
    Feb 27, 2013
  3. johnnnw macrumors 65816

    johnnnw

    Joined:
    Feb 7, 2013
    #3
    This actually is rather odd. Copying images shouldn't take much at all, especially only 150mb on an SSD. I'm trying to think what could cause this to be slow but I can't come up with much right now. Where are you copying the files from? I'm a little confused on that. SSD to SSD, like just moving them? Or the downloading from the internet is whats being slow?


    As for Roller Coaster Tycoon, considering you have the 15 which has dedicated graphics, it definitely shouldn't be lagging much at all. People play much newer games than that without much problem. Do you have all the updates for the game/is it meant to played on a Mac?
     
  4. Elektrikz thread starter macrumors member

    Joined:
    Feb 27, 2013
    #4
    Thanks for the reply mate!

    I am copying the files from downloads to where the game is located, basically just like programme files on a PC... sorry I am new to Mac! I have contacted Apple and the guy on the phone talked me through a few things but no help really, he did say it could be because of the amount of images in the file, we are talking around 3000 png images at a time... not that it should matter on a £2000 laptop lol!

    As for Rollercoaster tycoon, they are selling it on the App store so I could only imagine it is compatible with MAC, I cannot play it anymore as when I load it half the main menu is missing :(
     
  5. Mitchell112694 macrumors newbie

    Joined:
    Aug 4, 2012
    #5
    i have the same problem Apple put this in their system i believe, i have tried many Flash drive and SD cards and for some reasons the only ones that do not lag and the bar moves smoothly are ones made by apple or apple has approved them on their list, this is normal, also I'm not sure about the games, how much memory do you have?

    these are my stats:
    MacBook Pro Retina 2.7GHZ processor 16GB memory 512GB Flash Storage

    i seem to see no lag on my system
     
  6. Elektrikz thread starter macrumors member

    Joined:
    Feb 27, 2013
    #6
    exact same system as you :)

    Could be the game is simply just to old?
     
  7. ppone macrumors regular

    Joined:
    Sep 1, 2011
    #7
    can you download xbench (http://www.xbench.com) and just run the User Interface Test.

    What value do you get?

     
  8. Elektrikz thread starter macrumors member

    Joined:
    Feb 27, 2013
    #8
    Hello,

    My score was 150.17?

    Thanks
     
  9. agaskew macrumors 6502

    Joined:
    Dec 3, 2009
    #9
    2.7/16gb/750ssd:
    my score was 291.4 on the nvidia graphics chip
     
  10. ppone macrumors regular

    Joined:
    Sep 1, 2011
    #10
    What resolution are you using?

     
  11. Elektrikz thread starter macrumors member

    Joined:
    Feb 27, 2013
    #11
    Not sure just the standard resolution the Macbook arrived with, I have not changed anything as don't want to fiddle when I don't know what I am doing!

    is there a problem with the score?
     
  12. ppone, Feb 28, 2013
    Last edited: Feb 28, 2013

    ppone macrumors regular

    Joined:
    Sep 1, 2011
    #12
    On regular resolutions I was getting a score around 230.

    However I would run Xbench a few times to see what the median is.

    When I used a non HIDPI resolution and set gFX to 'Intel 4000' only

    I was getting a score of 414.

    http://imgur.com/LRnyLS5

    on the UI test.

    my system is base 2.3, 8Gb rMBP

    you can change your resolution to something non HiDPI with this app, see if that works for you.

    http://www.reddit.com/r/apple/comments/vi9yf/set_your_retina_macbook_pros_resolution_to/


     
  13. Elektrikz thread starter macrumors member

    Joined:
    Feb 27, 2013
    #13
    Ok here goes...

    Installed that programme to change resolution and switched to integrated graphics only and got this...

    Elements 286.32 1.31 Krefresh/sec

    I am running 1440 x 900 non HiDPI

    how does that look?
     
  14. ppone, Feb 28, 2013
    Last edited: Feb 28, 2013

    ppone macrumors regular

    Joined:
    Sep 1, 2011
    #14
    That looks pretty good.

    You can also try a higher non HiDPI resolution and play around.

    Do you notice any lag now?

    You went from 150.17 to 286 ish, that is a good UI performance increase.

    Non HiDPI 1920x1200 looks good as well.


     
  15. Mitchell112694 macrumors newbie

    Joined:
    Aug 4, 2012
    #15
    mine was 505.37 on high resolution

     

Share This Page