rMBP External Monitors not working....

Discussion in 'MacBook Pro' started by SpitUK, Sep 28, 2012.

  1. SpitUK macrumors 6502

    Joined:
    Mar 5, 2010
    #1
    Hi Guys, having a frustrating problem. I connect 2x 27" 2560x1440 Hazro monitors via 2 USB Dual Link DVI to Mini DisplayPort Adapters. They were working fine but have now stopped! The monitors display a blank screen, the Mac clearly switches to the external displays, the displays appear in the preferences and I can move them around, the mouse pointer disappears off the side as though going to the extra space. Just NO picture!

    I have tried connecting a MacBook Air and that works so I know the monitors and adapters are fine. I have shut down the Mac and rebooted, with and without the cables attached. I removed GFXCardStatus to no effect.

    Anything else I can try?

    I did install Steam in between using the external monitors but I cant see how that would cause an issue.

    Do you think the Thunderbolt ports could have blown?
     
  2. SpitUK thread starter macrumors 6502

    Joined:
    Mar 5, 2010
    #2
    Fixed it!!! I pressed gather windows and it brought the external displays preferences to the rMBP display and I discovered that the external monitors had reverted to a different res! I selected the correct res and the picture came on :)

    The reason the picture didnt display with a different resolution was the monitors are cheap versions that dont include any scaling so will only display the 2560x1440 res.
     
  3. rrm998 macrumors regular

    rrm998

    Joined:
    Jun 15, 2012
    Location:
    Houston, TX USA
    #3
    ^^^^
    Good catch! Something to keep in mind when I'm using my non-Thunderbolt monitor.
     

Share This Page