rMBP - forcing Thunderbolt Ethernet to take over from Wi-Fi when plugged in

Discussion in 'MacBook Pro' started by mustgroove, May 12, 2014.

  1. mustgroove macrumors regular

    Joined:
    Aug 14, 2006
    #1
    On my old non-retina MBP, if I was connected to Wi-Fi and then I plugged in an ethernet cable, the ethernet connection would take over. This is the preferred situation - ethernet is faster, and if you're plugged in that way you wanna take advantage of the faster connection.

    On my new rMBP, it doesn't seem to work like that - if I'm doing stuff over Wi-Fi but I then plug in my ethernet cable (with the Thunderbolt Ethernet Adapter attached), the ethernet connection doesn't take over automatically... File transfers to the rMBP often still proceed over Wi-Fi (which you can tell because of how slow they are) until I manually turn Wi-Fi off...

    I don't wanna have to do that though - surely there's a way to make it behave like the old machine used to? And yes, I do have Thunderbolt Ethernet as the #1 spot in "Set Service Order" in Network Preferences, but it seems not to make a difference :(
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    Normally, the 'Set Service Order' preference should work. I have no problems with mine that way.
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    That's what I do, so it goes to ethernet over wifi.

    I've not run into issues with it going to wifi when the order was set.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    This is normal even if you have set service order with TB/ethernet on top because the transfer is already underway on the other network interface (wifi in your case). You should see any new connections go over ethernet though.
     

Share This Page