rMBP FPS Max 31

Discussion in 'MacBook Pro' started by safinn, Aug 30, 2012.

  1. safinn macrumors newbie

    Joined:
    Aug 30, 2012
    #1
    I have installed windows 7 using bootcamp on my macbook pro retina and have installed fraps. When I run battlefield 3 the max I would get was 31 fps. I also went and ran fifa 12 also getting 31 fps as max.

    I think there is a max limit. how do I change this so i can get over 31. thanks.
     
  2. BlazednSleepy macrumors 6502a

    Joined:
    Apr 15, 2012
  3. safinn thread starter macrumors newbie

    Joined:
    Aug 30, 2012
  4. safinn thread starter macrumors newbie

    Joined:
    Aug 30, 2012
  5. Beta Particle macrumors 6502a

    Joined:
    Jun 25, 2012
    #5
    You probably have Vsync enabled, and the game is unable to run at 60fps.

    What Vsync does, is tie your framerate to your refresh rate. So with Vsync enabled at 60Hz, the maximum framerate your game can run at is 60fps.

    If the framerate drops below 60fps, say to 53fps, Vsync has to drop this down to 30fps, as it is the closest multiple of 60. (30×2 = 60)

    If your framerate drops below 30fps, it will then drop to 20fps (20×3 = 60) and if it drops below 20, it will go to 15fps. (15×4 = 60)


    This is done so that your framerate is syncronised with the display’s refresh rate. This ensures that the game runs smoothly, and avoids screen tearing.


    There are two alternatives to Vsync:
    1. Disabling Vsync: this will allow the game to run at arbitrary framerates, and as quickly as possible. So the game would run at 53fps using the example above, but the screen would constantly be tearing, and gameplay would not be smooth.
    2. Enabling Triple-Buffering in addition to Vsync: this caps the maximum framerate to the refresh rate (60fps at 60Hz) but allows the game to run at arbitrary framerates below that without introducing screen tearing. So your game would run at 53fps again, but because it is not a multiple of 60, movement in the game will stutter. Not all games support Triple-Buffering, though you can try to force it with D3D Overrider.
    What I would suggest is to either turn down your settings until the game can run at 60fps (and I would also enable triple buffering, because dropping from 60fps to 30fps stutters worse than 60fps to say 53fps) or accept that the game is only going to run at 30fps on your machine. It’s not really made for high-end gaming.


    If you use Nvidia Inspector, you can actually limit games to never run above 30fps (I would recommend setting it above 30 but below 60 though as slight variances can result in the game running just above 30—as is the case for you) which will eliminate stuttering from the game suddenly jumping up to 60 in less demanding areas.
     
  6. safinn thread starter macrumors newbie

    Joined:
    Aug 30, 2012
    #6
    Ahh Thank you. Will have a play with the settings and see what happens.
     

Share This Page