rMBP gfxCardStatus Stuck on Integrated

Discussion in 'MacBook Pro' started by Jeremy W, Jul 12, 2012.

  1. Jeremy W macrumors regular

    Joined:
    Aug 3, 2008
    #1
    I installed gfxCardStatus a few days ago, and it was working great. Out of the blue, my rMBP is now stuck on integrated graphics. I tried removing gfxCardStatus, and it's still stuck. Any program that would normally activate the discrete graphics (NetNewsWire, games, etc...) just hangs on launch.

    Can anybody help me?
     
  2. vanc macrumors 6502

    Joined:
    Nov 21, 2007
    #2
    Check System Preferences=>Energy Saver. Is "Automatic graphics switching" turned on?
     
  3. Jeremy W thread starter macrumors regular

    Joined:
    Aug 3, 2008
    #3
    Yep.
     
  4. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #4
    Sadly probably not, as "Automatic graphics switching" set to off forces the discrete GPU on 100% of time.

    here`s what I would try in orders of severity

    • https://github.com/codykrieger/gfxCardStatus/issues/
    • Reinstall gfxCardStatus
    • Shut the machine off fully and restart.
    • You can then start into Safe Mode by holding the Shift key directly after seeing the Apple logo when you turn on your machine, and then remove gfxCardStatus from your login items.
    • Run Apples hardware test if it passes, likely you will need to reinstall Lion, if it fails back to Apple.

    I would also contact the Dev for grfCardStatus as he may be aware of an issue, although from my understanding the app is only using Apples own framework and in general extremely stable.

    Do you have any other app installed that controls the GPU`s or more likely the resolution?
     
  5. Jeremy W thread starter macrumors regular

    Joined:
    Aug 3, 2008
    #5
    Well, you guys gave me an idea that fixed my problem. I disabled automatic graphics switching and rebooted. It was locked to the NVIDIA card, and everything worked. Then I re-enabled automatic graphics switching, and now everything is working normally again. I guess the toggling was all it needed.

    Thanks for the suggestions!
     
  6. Queen6 macrumors 603

    Queen6

    Joined:
    Dec 11, 2008
    Location:
    Enjoying Better Things
    #6
    Good news, no drama and we all learned a new fix :apple:
     
  7. xBlue macrumors newbie

    Joined:
    Jun 29, 2012
    #7
    I have the same problem. Usually it's stuck on Intel and no applications that need dedicated card will even start. This is fixed by rebooting the computer.

    I had this problem since ML and Retina MBP.
     
  8. Jeremy W thread starter macrumors regular

    Joined:
    Aug 3, 2008
    #8
    Did you try my fix? It worked every time for me, but I eventually just gave up and stopped installing gfxCardStatus and the problem went away.
     
  9. Orlandoech macrumors 68040

    Orlandoech

    Joined:
    Jun 2, 2011
    Location:
    Salt Lake City, UT
    #9
    gfxCardStatus is causing a lot of issues on rmbp machines. I would completely avoid it.
     
  10. xBlue macrumors newbie

    Joined:
    Jun 29, 2012
    #10
    I don't think that's a solution, because rebooting is enough to "fix" it.

    Since it doesn't happen often it's hard to know if it's fixed or not.
     
  11. kefaith macrumors member

    Joined:
    Feb 21, 2012
    #11
    I had this problem since the 2nd day I've owned it. I finally figured out the solution (I think, at least for me).

    I have gfxcardstatus installed. I noticed that if I leave it on force integrated or dedicated and do a shutdown / reboot, I will have the gfx stuck at integrated the next time it powers on. And to resolve this I can only do a reboot once more for it to function normally and be able to switch between the 2 cards freely.

    So the "solution" that I finally figured out after 2 whole months of playing around with it was that to set it to dynamic mode if you are gonna shutdown or do a reboot, otherwise u can set gfxcardstatus to force either cards and use it as per normal. Just remember to set gfxcardstatus back to dynamic mode before reboot / shutdown, and the next time u power on your rmbp you should not have this issue whereby it gets stuck on integrated card anymore.

    Hope this helps. Cheers. =)
     
  12. BruceBack macrumors newbie

    Joined:
    Nov 9, 2009
    #12
    good share :)
     
  13. bitninja macrumors regular

    bitninja

    Joined:
    Jun 16, 2007
    Location:
    San Jose, CA, USA
    #13
    Fixed this in v2.3 (coming out soon). Sorry about that. :)
     
  14. M5RahuL macrumors 68020

    M5RahuL

    Joined:
    Aug 1, 2009
    Location:
    Colorado
    #14
    Thanks for taking the time to fix this bug!!! :)

    Great job nonetheless :apple:
     

Share This Page